Support Forums

Can't use Netlify DNS with Namecheap domain

There are dozens of threads relating to this but not a single solution, I’m talking about the “A DNS zone for this domain already exists on NS1” error.

What are we supposed to do about it when using namecheap? I’ve seen solutions for Name.com but not this one. I can’t delete my nameserver, I can add custom ones but I have to add specific ones. So I tried adding the ones from this gist but it doesn’t seem to do anything.

I’m also worried the state for my domain will be bugged in netlify since half of the comments on the other threads seem like they needed someone to reset something.

Is there any actual fix? Something should really be done about this, many threads related to this error mention not knowing how to fix it on namecheap.

I’ve never seen this issue with any service provider before and I don’t get what’s so complicated about letting Netlify tell me what nameserver I should add. Right now I can’t know because it won’t pass the verification, so I’m stuck.

It’s a brand new domain so it shouldn’t already be registered.

Hi, @nialna. First, you can always use the external DNS instructions below:

This will always work, even if you are getting NS1 “domain already exists” errors.

If you really want to use Netlify DNS, we can troubleshoot that as well (and, again, there is always a solution). To get started troubleshooting, we need to know the domain name this error is happening for.

Would you please tell us the domain name that is affected?

You can post that information publicly or you can private message (PM) that to one of our support staff. I’ve confirmed that PMs are enabled for your community login. Please keep in mind that only one person can see the PM and this will likely mean a slower reply than posting the information publicly. Please feel free to reply to however you prefer though.

Sorry for posting twice, I replied in a thread and then realised the thread wasn’t specifically about Namecheap and figured it would be good to have a Namecheap thread for other people with the same issue.

I was trying to setup the Netlify DNS specifically. Creating a zone A worked for me but I wanted to set it up properly, which is where I’m stuck.

My problem is that on namecheap I can’t remove it from the default NS1 DNS without adding a new nameserver. but when I go to netlify, it won’t tell me which nameservers I’m supposed to add because I got the “domain already exists” error before I even get the chance.

So I’ve tried adding the nameservers that I found in the gist linked above:





But I don’t know if this will actually work with your system, because it might end up detecting it as being in NS1 but not “registered” in your system yet I suspect? Currently it’s not worrking when I try to verify it but it might still be propagating.

I’ll PM the domain

Hi @nialna,

Could you PM the domain to me too so I could check it?

1 Like

Hey @nialna,

Looks like this domain existed on Vercel before? Here’s what I received by dig NS +trace your-domain:

your-domain.       3600    IN      NS      ns1.vercel-dns.com.
your-domain.       3600    IN      NS      ns2.vercel-dns.com.
;; Received 92 bytes from in 29 ms

Chances are, Vercel also uses NS1 and thus, you might have to ask them to remove the zone before adding it to Netlify.

I suspect this is the default Namecheap nameserver, because I never specified any nameserver myself. It’s just what the domain came with.

Basically my problem with figuring out how to fix namecheap is that as soon as I bought the domain it was on ns1 and I couldn’t verify it with Netlify.

So now I’ve tried adding those other DNS manually but I’m not sure they’re the right ones or if it will work. Would be useful if the domain verification page in netlify showed which DNS servers to use because I only found it from this github gist

Hi @nialna,

Randomly copying the DNS won’t work as Netlify doesn’t have a zone for that domain. I believe you need to contact Namecheap to help you with this, but I’d be surprised if their default nameservers actually point to Vercel.

In any case, there actually exists a DNS zone for this domain on NS1 and it’s out of our control. Maybe you can contact NS1 directly and see if you can get help with this as they won’t tell us who owns this zone. The easier way would be to use external DNS like suggested above.

I just bought the domain and didn’t do anything with it so the only way this vercel domain is there is because Namecheap set it. I assume it’s what their default nameserver is. Only thing I did since then is switching it to the DNS I found online, hoping it would fix it. Their UI didn’t let me remove the name servers so I had to set it to something.

A lot of people on various threads had this issue with domains from namecheap (and also name.com, but apparently it’s easier to fix there).

and so on.

All those threads mention the same issue on namecheap, they bought a domain and somehow it’s detected as already on NS1. I’m not expert in the details so I don’t know what’s the properr way to fix this.

but it would be useful to have info somewherre on what to do, because so far the only thing I’ve been able to try is setting those DNS manually that I found on Google because there is no other info. if I wasn’t supposed to do that then I don’t know what to actually do.

Regardless, namecheap is a pretty common provider and if you just tell anyone who bought a domain on namecheap “sorry you’re on your own”, that’s not very useful. this isn’t a one time mistake from me, it’s clearly happening to lots of people.

Hi @nialna,

I’m sorry, but I really don’t think we can be of any help here. It’s not like we don’t want to, it’s just that it’s not something we can help you with as it’s stuff beyond our control. Let me explain why:

In all those threads you can probably read and generalise that there are 2 kinds of cases, 1 in which the DNS Zone existed in Netlify’s NS1 account which we could then delete and 2, we have no idea who has that zone in NS1 and thus, we’ve asked them to contact their domain provider.

Yes, I agree NameCheap is a big provider probably, but if it makes some settings that makes the domain unusable at Netlify, we can’t do anything about it. If the domain existed in our NS1 account (it doesn’t), we’d have removed it and you were free to add it to your account.

Some of them have also reported issues with Namesilo and others and we do get many such tickets in the Helpdesk too. For some of them, the zone exists in our account, which we can then remove, but for some, we’re helpless as we don’t know where the domain exists.

I didn’t mean to say you’re on your own. I just suggested you to use external DNS as it seemed less hassle than contacting NameCheap and/or NS1 to figure this out.

About you adding the nameservers of Netlify by finding them on Google, it won’t work because:

  1. Netlify doesn’t have a record of you creating a DNS zone for the domain and thus, it won’t respond to the requests.
  2. Netlify gives different nameservers to different users. While, it’s from a fixed set of records, there are some numbers that do change.

I just even tried to manually create the DNS Zone for you in NS1, but we get the same error there too:

NS1 API Request Failed on PUT /v1/zones/your-domain zone already exists
Feel free to report this error to support@ns1.com

As far as some info as to what to do is concerned, the threads you shared have some useful info like this:

I’ve contacted Namecheap support and also NS1, will see what they say.

NS1 doesn’t seem to want to give support to anyone who isn’t registered with them, so I don’t really know how to remove a DNS record on their end that I never created…

I assume Namecheap is creating this NS1 record as that’s really the only possibility, the only time I changed ns records was to try to add the netlify ones


Do let us know what they say and let us know if there’s anything needed to be done from our end to assist you with this.

Namecheap says they’ve never set anything up on NS1, and I’m waiting on NS1 for now. I’ve tried removing the nsone nameserver I tried adding since you mentioned that won’t work so I’ve reverted to the default namecheap serrver (which now appears on dns checkers as dns1.registrar-servers.com and dns2.registrar-servers.com).

So that part seems ok, but when trying to configure my domain on Netlify it still says it already has a record on NS1.

I guess the only option now is for NS1 to fix the issue?

Hi, @nialna. Currently, I do see that a Netlify DNS zone for the domain in question was created about 10 hours ago so it appears you did resolve this.

Note, many other SaaS and PaaS companies use NS1 for DNS infrastructure (NS1 itself being DNS IaaS) . NS1 is quite popular as well which only compounds the issue. (By the way, personally, I feel they deserve to be popular as I think NS1’s services are top notch.)

The issue is that only one zone can exist but the API doesn’t tell you who created the other zone. The API cannot tell companies who created the other zone as this would be a potential security issue or otherwise leak private information.

So, if a company creates a DNS zone at NS1 and then another company tries to do so, this “domain already exists” error occurs.

When this happens the two general types of solutions are:

A) The domain owner finds the other service they created a DNS zone for this domain at and delete the zone there.


B) The domain owner contacts NS1 directly and asks them to delete it.

Solution A is faster. Solution B always works but is slower than A.

Solution B looks something like this:

  1. Create an account at NS1 (which is free and also needed to open a support ticket with them).
  2. Open a support ticket at NS1 asking that the “DNS zone for domain X” (whatever the domain is) be deleted.
  3. I assume (as I’ve never done it personally) that then there is a verification process - typically creating a TXT type DNS record to prove you control the domain.
  4. NS1 confirms the TXT record and deletes the zone.
  5. A new zone can be created at NS1 by Netlify (or any other company).

Now, sometimes there is a “phantom zone” (and I wish I had a better name for it). This is why we ask for the domain name - so we can see if that is happening. (This type of issue is very rare but not unheard of.)

Thanks for all the info, yes I did solve it in the end, NS1 support helped me and asked Vercel to remove my record from it, it seems.

I still don’t know why my namecheap domain had an NS1 record as soon as I bought it. The vercel one was (I think) because I tried to use hashnode (although I never changed nameservers to it so I have no idea how that could have happened automatically). but even before I tried hashnode my domain wouldn’t work on Netlify as soon as I bought it with the NS1 error, and I still don’t know why. Namecheap said they don’t set their domains on NS1 and couldn’t help me. This domain was never set up on another service before because I tried to set it up on Netlify as soon as I bought it, so it’s strange.

Unless a previous owner could have created an ns1 record and it could still exist after expiration? I don’t know if that’s possible.

So it’s all good for me but frustratingly I still don’t have a good answer as to why this happens in the first place.

Hi @nialna,

Yes, the only possible explanation might be that the zone was created before, the domain expired and even then the zone was never deleted. Nevertheless, it’s great you got it solved.

About this:

The explanation is this:

Vercel made the other zone. I say this based on this:

If there are other questions about this, @nialna, please let us know.