Can't rootcause a failing build since the Netlify incident from Oct 13

Hello,

Yesterday, I started with converting a Hugo based static site hosted on Netlify to elm-pages. I’m doing this on branch elm-pages in my git repo.

Every of my changes work correctly when building on my Mac.
I am using the branch deploy from Netlify to preview the results: https://elm-pages--ringo.netlify.app

There are a number of commits on that branch. The Netlify build of the first two commits worked correctly (initially):

  • 12e737d
  • 08d9acf

Around the time I pushed my third commit, the Netlify incident from Oct 13 started. The third commit only changed content of my site but not any site configuration:

  • 854c0ea

No matter what I pushed afterwards, all subsequent builds fail. Here is link to an example build log:

Every failing build has the same error.
I tried rebuilding a commit which failed before with the cache cleared but that didn’t work. I then retried a rebuild of the second commit (which succeeded initially) but this one now fails too!

I noticed that Netlify builds with Node 10 by default while I am using Node 12 on my Mac. On of the last commits is updating the build setup on Netlify to Node 12 as well, but still the build fails:

  • 2f81f15

Last resort: follow the instructions on how to debug failing builds as adviced to me via Twitter.

I pulled the netlify/build:xenial Docker image and cloned the build-image repository. When running the build on my Mac via this emulated environment I get the same build failure.

So given I can’t get to a working build again since the incident of yesterday, I assume there was a change to the build setup or build image which impacts my setup. Any help from Netlify people much appreciated! :pray:

Closing note: I also discussed this on the Elm Slack, channel #elm-pages with the author of the site generator and he is as puzzled as I am.

Edit: I tried documenting extensively, but had to remove a number of links. As a new forum user, I have a limit of 6 links. :frowning:

Hiya @ringods and welcome to our community! Sorry it’s taken us so long to get back to you. As far as I can tell, you got a successful build on that branch on the 14th at ~noon UTC?

Do be aware that running elm directly from cache as you do in that successful build is probably not good idea - your cache may not be available sometimes. I’d add what you need to your repo instead, and run it from there, since we always have your repo cloned before we start the build.