Can't add domain that I own as custom domain to site

Hello Community,

I own the custom domain “madd.dev”, however when trying to add it as a custom domain to my netlify site " https://madd-dev.netlify.app" I get an error saying that the site is already in use.

Has anyone else had this issue, if so how do I resolve it?

Thanks in advance for any help.

Hey there, this is happening because the custom domain you’re trying to use already exists on Netlify under a different account.

If you have some idea of who might be using the domain (maybe a previous collaborator or an agency you’ve worked with in the past?), the quickest way to get this resolved is for you to contact that person directly and ask them to remove the domain from their account here:

https://app.netlify.com/sites/SITE-NAME/settings/domain#custom-domains > “Options” dropdown > “Remove domain”

If you’re not sure, please verify domain ownership and let us know by responding here when that’s done. If the verification is successful we can remove the domain from the other account so you can use it on yours.

Hey @perry, thanks for chiming in!

I just purchased the domain a couple of days ago so I wouldn’t think that someone else could be using it.

Hi, @christiangentry. If you complete the verification process, we will happy to remove it from the other account and/or site using it.

Thanks @luke !!!

I just added the TXT record. Please let me know if I need to do anything else.

Hi, @christiangentry. I don’t see that TXT record currently:

https://toolbox.googleapps.com/apps/dig/#TXT/verified-for-netlify.madd.dev

There is no answer for the lookup above. This domain appears to be using Netlify DNS under the same account as the site. Based on this I have removed the custom domain from a site on another account where it had been added previously.

You should be able to add this custom domain to the site settings of madd-dev now. If this doesn’t work and/or if there are any questions, please let us know.