Home
Support Forums

Can't access my site via HTTPS in China Mainland without VPN

Here is my netlify site name: https://objective-curran-d9d5c8.netlify.app/

My custom domain is: https://imageslr.com .

Recently, I can’t access my site without VPN. In fact, if I visit my netlify site name directly, it works. However, if I visit my custom domain, there will be a time_out error.

By running nmap -Pn imageslr.com -p 80,443, I got the following message:

PORT STATE SERVICE
80/tcp open http
443/tcp filtered https

So I renew the certificate in site setting, but It didn’t work. And I set a custom certificate for my custom domain, yet it still not worked.

Thanks for your help.

Hey there, @imageslr :wave:

Welcome to the Netlify Forums, and thanks for reaching out about this! I would suggest starting with this thread to learn more about why this is happening:

I tried the following steps and my site can be loaded correctly!

  1. remove custom domain settings in Netlify.
  2. remove all dns resolve records of my domain in Domain Provider (which is Tencent Cloud in my case).
  3. add custom domain settings in Netlify.
  4. add CNAME records (@, www) in Domain Provider.
1 Like

Hey there, @imageslr :wave:

Thanks so much for coming back and updating us with this! Your knowledge sharing will definitely be beneficial for future members who encounter something similar. :netliconfetti:

1 Like