Support Forums

Can't access Bitbucket team repositories - master does not exist or you do not have permission

@JesusCrow have you tried clicking on the BitBucket username when adding a site to select another team’s repos to list? I’ve attached an image with that selector highlighted.

I don’t use VPN, but it sounds like a similar issue.
It would probably be fixed if I could just re-authorize BitBucket to Netlify. Yesterday when I tried to create a new site, BitBucket skipped authorization (permissions request window), so I think that it could be a problem with not enough permissions given some time ago (i.e. when I tried Netlify half a year ago and I didn’t want to allow it to see everything on my BitBucket account so I only gave permissions for personal repos). At least that’s my guess atm.

I got scared for a moment that I didn’t notice it :smiley:
I just checked again, there is no selector at the marked place.

Yes, both of them are the same issue. We’re facing it too.

If you’re not the admin of the team, you can’t see any repositories under that team (even if you are admin of some of the repositories under that team).

N.B.: Doesn’t help even if you reauthorize your Netlify account with Bitbucket.

1 Like

That is how it is supposed to work. Only team admins can do the operations needed - adding deploy keys and webhooks to a repo. Sorry I don’t have better news for you, but you can of course use the CLI to link with the team admin’s help:


I also have this issue with accessing team repositories from Bitbucket.
Repository admins are able to add deploy keys and webhooks, without needing to be a team admin. Mandating the need to be a bitbucket team admin to configure all sites is infeasible.

Interesting, do you have a link to their API or permission docs that show this? It is contrary to our experience and is why we have “gated” the feature like this.

I think the issue is the distinction between the concept of team admins and repository admins in Bitbucket.
I have never been a team admin with my current company - only a team member/contributor. Previously in Netlify I have been able to provision sites where I was an administrator of the team’s repository but not a team admin (this was working at least a month ago). I don’t believe the Bitbucket API has changed since then.

I’d imagine you’d want to look for a user’s teams in bitbucket where their role is a ‘member’ and then find the team’s repositories where the user has the role of ‘admin’.

This link mentions how repository admins can create webhooks.

Thanks for those details, Henry! I’ve gotten a feature request filed as I have confirmed it affects others in your situation as well. In the meantime, your options are:

  • as I mentioned use the CLI
  • have the team admin use the UI (though you’d have to invite them to your Netlify team)
  • try using the API: [Common Issue] Linking a repository via API which may allow you to self serve (please let me know if you do try this and it works or fails!)
1 Like

Thanks for the update. As you suggest, the best option currently will be to use the CLI.

1 Like

Same issue here as well.

noted, @gyrad. Sorry for the inconvenience. Have you tried using the CLI?

Thanks for your reply. I have tried the CLI and it just doesn’t work. I was able to resolve the issue by having my Bitbucket account elevated to team admin status. Jtlyk, when I spun up a site on Zeit, I was able to get access to the repo even without me being a team admin.

Thanks for that information, @gyrad. We have this community topic and the issue filed for this cross-linked. We will post and update here if/when the issue is known to be resolved.


Having the same issue, hoping your team can get it resolved.

1 Like

Confirmed that I can access the BitBucket repo in question on AWS CodeBuild. I have admin priveleges for the repo but not the team.

thanks for chiming in, @matthew - i’ve added your information to the issue we filed on this. Do any of the solutions mentioned by fool above work for your circumstances?

Thanks for the response @perry.

If the CLI gave that message, did you follow Bret’s advice to the person who filed that issue and use --manual? That should work as expected.

Thanks for the reports of this, and for everyone’s patience while we find a solution. As identified by the descriptions in this thread, the problem affected repos that you have admin permissions for within teams where you’re not an admin. With the various ways Bitbucket gives us to retrieve the list of repos, that scenario was falling through a crack.

We’ve deployed a change within the last day to address this and you should now be able to choose the repos that were previously missing from that list. You can read about it in Updates.

I’d love to hear if this is now working for you. It was a nuanced issue, and so I’d definitely like to know if there’s anything still preventing you for accessing the repos you need to access.

1 Like