Can't access any sites due to a HSTS error and an expired cert

Hello, I looked around and it seems like everyone has issues with SSL on custom domains - but I keep having them with default, Netlify-issued ones!

Wherever they are, keep getting an NET::ERR_CERT_AUTHORITY_INVALID error and any browser complains a HSTS failure because of an expired certificate. I can’t even skip and proceed at my own risk - the sites are inaccessible at all.

Our agency website, worked fine on the Netlify domain until some point after we switched to a custom domain, which works fine. I’m not sure when it happened and why, but I noticed it after I tried checking out a branch preview, like this one.

The weird thing is that I’m experiencing the same issues on projects I deploy on a completely different, personal account where I just try things out in my spare time. For example this one:

Is anyone else experiencing these issues?

Hey @valshuty,
Sorry to hear that you’re running into this. I took a look and am able to load your sites, including your branch preview, from Firefox on the US west coast. does not seem to exist in our database. Maybe you’ve deleted that site since writing in?

What would be helpful for us in troubleshooting is an x-nf-request-id and some information about your browser and network. Which browser is this happening for you on? This error can also sometimes be caused by interference from firewalls or browser extensions- could either of those be true for you?