Support Forums

Cannot use subdomain for site when root domain is set up in team


Recently I added my domain to Netlify, to the default team created for my user. I then created a site and attempted to set its domain to a subdomain of the one set for the team (e.g. set example.com as the team domain, then set foo.example.com as the site domain), however it isn’t letting me do that, saying another site is already using it.

I migrated the domain’s DNS from fastmail and it is set up using the same values, so preferrably I wouldn’t have to remake the domain and enter the DNS again.

The team is alllyd, and the site is aldscrn.

hey there, its a bit hard to check without knowing which subdomain and domain you are trying to work with, but generally when we see that error, this is happening because the custom domain you’re trying to use already exists on Netlify under a different account.

If you’re not sure, please verify domain ownership and let us know by responding here when that’s done. If the verification is successful we can remove the domain from the other account so you can use it on yours.

Thanks for the response.

The custom domain is under my account already.

The domain is alduino.dev, and anything can be the subdomain (I’ve even tried with typing random characters which still doesn’t work)

Seems that someone named Zach B uses “alduino.dev” on his team, which blocks your usage in a different account. Do you know them? If not, I can write to them to let them know we’ll remove the domain from their site to unblock your usage, since you controlling the DNS zone trumps any other config (from sep 2019) that Zach has in place.


That’s me! Are you sure that isn’t this acocunt? I did think I had an old account that I forgot the email and password for though…

Edit: Looks like I can’t add a site that uses the root domain either, although it is added to my Netlify team.

Yes, you will need to sign in to your old account and delete it from there, to use it here. As a hint, there is no password set on that other login: you signed in with GitHub, last login on 16 Sep 2019.

Oh cool, thanks. I’ve deleted that account now and it works!