Cannot download deployment


  • Clicking on the download button returns “generating zip” and then, later, “error during download”
  • Tried in Chrome and Safari
  • eloquent-lalande-6f6620

Any one else had this issue?

Hi, @sparkchange, and welcome to our Netlify community site.

How many files and what is the total size of those files in the deployment being downloaded?

Hi @luke, I have the same issue. I’d like to download Wordpress pages for which I lost access. Is there a way to bypass this download error? Thanks!

Hi, @yve, and welcome the the Netlify community site.

Which site is giving this error? I’ll see if we can find another way to download the deployed site.

Hi @luke, thanks for getting back to me, really appreciate it! :slightly_smiling_face:

It’s this page:
Would be great to get the files from the latest successful deployment: Jul 30, 2019 at 12:59 AM.


Hmm, we’re not easily able to get at that deploy either - it’s pretty big and that only really works for smaller deploys. I do not think we’ll get a fix, very soon though.

So - in the meantime, could we maybe help with the root of your issue? I think you probably don’t want to download the deployment just for the sake of downloading it - so maybe you’re debugging some other issue we can try to help you work through?

Same problem here, trying to download our Gatsby site (pretty big), to debug _redirects problems
Why is it erroring out?

Hey Tobbe, sorry you are having problems with your redirects, sounds like we might have more success digging into why those won’t work - your site might be too big to be reliably downloaded this way, unfortunately.

What site is this concerning and what’s the problem with your redirects?

We’ve solved the problem. It was just a matter of giving it some time, and clearing caches

But please fix your download problem. It’s super helpful to be able to download the deploys to debug :slight_smile:

Hi, @Tobbe, we need a link to the deploy which cannot be downloaded to research the issue. If you would like us to do so, please send us a link to the deploy which cannot be downloaded.

Can I send you the link in a DM, or do you have an email I can use? I don’t want to share the link in public. Thanks :slight_smile:

You can also just send the “deploy id” which is the last path segment in the URL.

By “last path segment”, I mean with this starting URL:

then the deploy id is 5ee8ac300843827bf46feb8e.

You can private message (PM) that to one of our support staff if you prefer. I’ve confirmed that PMs are enabled for your community login. Note, that only one person can see the PM and this will likely mean a slower reply than posting the information publicly. Please feel free to reply to however you prefer though.

That works :slight_smile: Here it is 5eeb4504fab490701033939e Just tried downloading that one and I just get “Error during download”

Hey @Tobbe,
We’re looking into this. Part of the problem is that there are surprising number of moving parts involved in the “download deploys” feature, so we’ve filed an issue for some improved error logging at least. We’ll update here if there’s movement on that or if we learn more.

I’d also need a download of a rather large deploy and it’s not working. Any way to work around this?

ID is 5d3f7a600e3cc30009f7b4c4

Hiya @xmartin_dv and welcome to our community!

There is no easy workaround for deploys of that size (it’s around 500MByte total).

Can you tell me more about what your goals are in downloading? I can more easily check on single files than I can export all 2,154 files in a way you’ll be able to download, and I could perhaps instead guide you to a local build that produces the same output so you can make your own copy, anytime you want :slight_smile: (that second category of advice starts here in case it sounds appealing:

I have the same problem here.

Console shows:

Access to fetch at ‘’ from origin ‘’ has been blocked by CORS policy: No ‘Access-Control-Allow-Origin’ header is present on the requested resource. If an opaque response serves your needs, set the request’s mode to ‘no-cors’ to fetch the resource with CORS disabled.

Tested both on Chrome and Firefox.

I need this file because my reverse proxy is not working properly : I want to check that one file is there (though I’m pretty sure it is, it’s just a confirmation).

Hi, @brunorzn. Thanks for asking about this. I’m not getting any CORS errors when I test downloading deploys.

Would please confirm that you are not running any adblockers, javascript blockers, or anti-virus that could be causing this?

If you are sure, what is the deploy id for the deploy which doesn’t download?


Thanks for your quick answer. Yes, I’m not running any adblockers, javascript blockers or anti-virus on Firefox, which has the same behaviour.

Nevertheless, I managed to download the archive for the production branch (but not any deployed branch where I had this problem), so this is less urgent for me now.

Example of not working deploy id : 5fc5231b2ca6e500079b9782

Maybe it’s due to the size of the archive ?

Thanks anyway !

Hi @brunorzn and sorry to be slow to get back to you! We are still considering how best to improve this part of our platform - there some under-the-hood considerations that are making this a tricky process to improve, but we hope to have something in place soon and will let you know when that’s the case.

Good to hear you were able to download the archive for the production branch,

as far as other branches go, is the API endpoint where you could see individual files if that is helpful?