Home
Support Forums

Cannot access to Deploy Previews

Hi there,

I’m trying to use Deploy Previews on my websites.
I’m using a self-hosted gitlab instance.

Our HTTPS repository URL are limited so I was not able to connect to repository and had to setup a Netlify site from the Netlify CLI using SSH repository address.

In this case, I cannot use Deploy Previews because the feature is not available from site settings on Netlify UI (related maybe to manual site setup).

Is there a way to achieve it ?
Maybe something like setting SSH repository URL instead of HTTPS using Gitlab integration from Netlify back-office ?

image

I would definitely love to use it from our Gitlab instance.

Thanks a lot for your precious help.

hi there,

if you are doing a manual deploy from the CLI, do you have a netlify.toml? if yes, can you share it here - there may be some settings that are missing. thanks!

Hi Perry,
Thanks for your feedback.
I have toml file, but there is pretty much nothing in it.

# example netlify.toml
[build]
  base = "src/"
  command = "npm run generate"
  functions = "netlify/functions"
  publish = "/dist"

  ## Uncomment to use this redirect for Single Page Applications like create-react-app.
  ## Not needed for static site generators.
  #[[redirects]]
  #  from = "/*"
  #  to = "/index.html"
  #  status = 200

  ## (optional) Settings for Netlify Dev
  ## https://github.com/netlify/cli/blob/main/docs/netlify-dev.md#project-detection
  #[dev]
  #  command = "yarn start" # Command to start your dev server
  #  port = 3000 # Port that the dev server will be listening on
  #  publish = "dist" # Folder with the static content for _redirect file

  ## more info on configuring this file: https://www.netlify.com/docs/netlify-toml-reference/


[[headers]]
  for = "/*"
  [headers.values]
    X-Frame-Options = "DENY"
    X-XSS-Protection = "1; mode=block"

    #  Multi-value headers are expressed with multi-line strings
#     cache-control = '''
#     max-age=0,
#     no-cache,
#     no-store,
#     must-revalidate'''

    # The Basic-Auth header may not be available on all plans.
#     Basic-Auth = "test:test"

Thanks for your help.
Best regards.

Hi @ghislefou,

We’ve replied to your ticket in the helpdesk. Let us know if you didn’t get an email.