Cannot access CMS admin page

I am deploying a GitHub repository to Netlify which appears to be set up correctly (

I followed the Netlify-CMS instructions for setting up the admin page by adding lines to the main index.html files in my site.

I added Git-Gateway, invited myself as a user, replied to the invite and was confirmed as logged in.

I then tried to open the admin page at, but received a “404 Page not found” error.

How can I fix this? I have been trying to get a viable Netlify site working for over three months now. The set-up process is one of the most confusing I have ever encountered. I follow tutorial instructions carefully, and still nothing works. Why?

I know I could develop the site locally, but the admin page is more convenient and is SUPPOSED TO WORK.

As of writing, my site remains unusable because of the apparently non-existent admin page issue. If anyone can help, please let me know.

Can you share the Github repository so we can have a look to find out what’s wrong?

Here is the repo:

I realized that I hadn’t set up the admin directory containing the index.html and config.yml files. I just spent another hour adding code snippets to:


Pushed everything back up to Git > redeployed on Netflify > deleted myself as a user > reinvited myself as a user > accepted invitation > tried to open > 404 Page not found.

The problem may be something to do with Jekyll using _ before folders - I set up the admin folder as _admin for this reason, and config.yml inside it as _admin/_config.yml - the site’s default config file in the main directory is named _config.yml.

I followed the config instructions on this page as closely as I could, but the config setup is not specific to setting up admin for a Jekyll site so there must be something wrong with my config.

Update: I corrected the _admin directory to admin and now now longer get the 404 Page not found message. Instead, the URL shows as follows:

But the page remains blank with no admin interface.

i’m looking at your code and i am seeing this:

see the red console errors that are indicating that something is unhappy.

I also noticed that the page took a while to load.

What’s odd is that the versions you are loading in here via the head don’t seem to match the requirements listed on npm:

leads me to wonder whether you are loading everything in that is required for netlify cms to run.

did you grab the code to load in the packages from a cdn for netlify cms from our docs or other site we can look at to confirm?

my hunch is that all of your paths are correct now, but the fact that they were wrong before obscured the fact that you are missing some requirements :thinking:

but, we’re a step closer! we’ll get this working soon i’m sure :muscle:

Try moving the CMS script to the end of the body tag, and remove the _site folder from your repository (and add it to your .gitignore file).

<!doctype html>
    <meta charset="utf-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0" />
    <title>Content Manager</title>
    <script src=""></script>
    <script src="^2.0.0/dist/netlify-cms.js"></script>

It also seems you tried to combine Jekylls’ and the CMS’ config.yml file, so that’ll need some attention.

I opened up a pull request in your repo that should get you going.

1 Like

I don’t really understand what you did but that seems to have fixed it! I can now access the admin page. I really appreciate your help with this.


You can view the changes I made side by side here