Can’t edit the value of a DNS record: DNS cannot be managed directly

Hey guys,

Already had this issue on another account, and it worked with the Netlify team making the change.
so i’m reposting but for this current domain:

I’m using Netlify DNS to manage my domains, and until this point everything worked fine.
Now i have a CNAME redirection that works, but when going to the url the page says not found.

It seems that when i created this CNAME redirection, Netlify automatically created another one that redirected to somewhere i don’t want to, and i can’t edit it.

Is it possible to edit or delete these record marked as This is a system record that cannot be managed directly

Hey there,

I’ve marked this record as editable. If you return to the UI, you now have the option to delete the record!

1 Like

Hey Parker,

this seems to do the trick, but we’d also need to be able to edit the www. one

Whoops, that’s my bad. That one’s been marked as deletable for you too :+1:.

1 Like

Thanks a lot Parker :wink:

1 Like

Hi ! I’m having the same issue with a DNS NETLIFY type entry. This is the one starting by “api.” …

Could you please delete it or give me the possibility to ? Thanks :slight_smile:

Sure, if you give us the site name, custom domain, app ID or any other identifying information :wink:!

Hey, the DNS Record to delete is the NETLIFY type api… pointing to …

Thanks in advance :slight_smile:

I’ve updated that record so it can now be deleted, @flyludz :slight_smile:

Thanks @Pie ! It worked fine :slight_smile:

1 Like

Hi ! I’m having the same issue with a DNS NETLIFY type entry. My root and www domain are pointing to Could you please help me remove them? Thanks.

which custom domain is this regarding, @eagle?

Awesome, they should be removable now :+1:

Thank you @Pie! It worked.

1 Like


Could you please help me remove domain


hi there, we changed a setting - you should be able to remove that domain now. Let us know if this doesn’t work for some reason.

Thanks bro @perry. It worked

1 Like