Home
Support Forums

Builds of new branches fails - Cannot find module 'dot-prop'

Hi there!

I need advice to debug deploy
https://app.netlify.com/sites/daviddarx-portfolio/deploys/5f9b45f9654d1f000762f25a and
https://app.netlify.com/sites/daviddarx-portfolio/deploys/5f9b4a96a38aaf34118037dd

I made two new branches and can’t deploy them like I deployed many others branches before. The given error is each time the same: [a file name]:undefined:undefined: Cannot find module ‘dot-prop’

It’s strange, because I created these branches from master. Once the deploying failed there, I went back to the master and made a test deploy, and there everthing is working.

My website is vue-js based and packed with parceljs.

Do you have any idea what could the problem be? Thank you a lot!

Hi @daviddarx, welcome to the community.

I’m not quite sure but it looks like ‘reset-css’ is the one using dot-prop. In that branch, have you tried running ‘npm update’ locally and then pushing the resulting package-lock.json to your branch?

Hi Dennis,

I ran npm-update and now it’s working! Thank you very very much! <3

1 Like