Home
Support Forums

Build that once worked is failing

Dear Support Team,

My build is failing all of a sudden. Could you please help out?

the logs can be found here:
https://app.netlify.com/sites/gifted-shirley-7ac6e1/deploys/6159ae2519ab3e1b08fde939

6:52:15 PM: ./node_modules/react-icons/fa/index.esm.js
6:52:15 PM: Cannot find module: ‘…/lib’. Make sure this package is installed.
6:52:15 PM: You can install this package by running: yarn add …/lib.
6:52:15 PM: error Command failed with exit code 1.
6:52:15 PM: info Visit yarn run | Yarn for documentation about this command.
6:52:15 PM: ​
6:52:15 PM: ────────────────────────────────────────────────────────────────
6:52:15 PM: “build.command” failed
6:52:15 PM: ────────────────────────────────────────────────────────────────
6:52:15 PM: ​
6:52:15 PM: Error message
6:52:15 PM: Command failed with exit code 1: yarn build
6:52:15 PM: ​
6:52:15 PM: Error location
6:52:15 PM: In Build command from Netlify app:
6:52:15 PM: yarn build
Here’s what I have tried so so far. nothing has worked.

  1. placed “build”: “CI= react-scripts build” in package.json
  2. NETLIFY_BUILD_DEBUG = true

Please help out. I have run out of ideas on this.
Thank you.
Prasad

Hi All,

I got this fixed with one change.

  • I upgraded react-icons to 4.3.1

I also used a flag for verbose deploy logs.

NETLIFY_BUILD_DEBUG=true

Ultimately all is well.

Thank you.

1 Like

Hey there, @praskatti :wave:

Thanks for following up and sharing your solution. This will definitely benefit future Forums members who encounter something similar. :netliconfetti: