Home
Support Forums

Build Failed Error

Hello there,

I am facing build failed error always.

From Logs:
10:46:45 AM: [05:16:45] Could not resolve routes
10:46:45 AM: [05:16:45] Error: write EPROTO 140546426259328:error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure:…/deps/openssl/openssl/ssl/s23_clnt.c:802:
10:46:45 AM: at WriteWrap.afterWrite [as oncomplete] (net.js:868:14)
10:46:45 AM: Nuxt Fatal Error :frowning:
10:46:45 AM: error Command failed with exit code 1.
10:46:45 AM: info Visit yarn run | Yarn for documentation about this command.

I have tried all possible steps and checked all old similar ticket but nothing works.

And on local it is working perfect.

Can anyone help?

Thanks & Regards
Gaurav Vashisht

Hi @gauravvashisht_gswtp

As you have only provided a small portion of your log, it is a little hard to say what is wrong.

I see you are using NuxtJS. Are you running the generate command?

Yes, I am runnning yarn run generate command.

Are you able to share the full log (if your logs are public, share the URL)?

Are you able to share your git repository?

10:38:02 AM: Build ready to start
10:38:03 AM: ---------------------------------------------------------------------DEPRECATION NOTICE: Builds using the Trusty build image will fail after September 19, 2021The build image for this site uses Ubuntu 14.04 Trusty Tahr, which is no longer supported.All Netlify builds using the Trusty build image will begin failing in the week of September 19.To avoid service disruption, please select a newer build image at the following link:app.netlify.com/sites/jolly-carson-732828/settings/deploys#build-image-selectionFor more details, visit the build image migration guide:answers.netlify.com/t/end-of-support-for-trusty-build-image-everything-you-need-to-know/39004---------------------------------------------------------------------
10:45:53 AM: build-image version: 8e315e54bc4032a32e73290be556cde4f8348c12
10:45:53 AM: build-image tag: v2.8.2
10:45:53 AM: buildbot version: 76af94f42647b2019c5925a515cc8332b4883b85
10:45:53 AM: No cache source specified, skip fetching cache
10:45:53 AM: Starting to prepare the repo for build
10:45:54 AM: No cached dependencies found. Cloning fresh repo
10:45:54 AM: git clone git@bitbucket.org:darkroast-digital/discover
10:45:55 AM: Preparing Git Reference refs/heads/master
10:45:55 AM: Starting build script
10:45:55 AM: Installing dependencies
10:45:56 AM: Downloading and installing node v8.17.0…
10:45:56 AM: Downloading
10:45:57 AM:
#############
10:45:57 AM: 19.1%
10:45:57 AM:
###########################################################
10:45:57 AM: ############# 100.0%
10:45:57 AM: Computing checksum with sha256sum
10:45:57 AM: Checksums matched!
10:45:59 AM: Now using node v8.17.0 (npm v6.13.4)
10:45:59 AM: Attempting ruby version 2.3.6, read from environment
10:46:00 AM: Using ruby version 2.3.6
10:46:00 AM: Using PHP version 5.6
10:46:00 AM: Started restoring cached node modules
10:46:00 AM: Finished restoring cached node modules
10:46:00 AM: Started restoring cached yarn cache
10:46:00 AM: Finished restoring cached yarn cache
10:46:00 AM: Installing yarn at version 1.3.2
10:46:00 AM: Installing Yarn!
10:46:00 AM: > Downloading tarball…
10:46:00 AM: [1/2]: https://yarnpkg.com/d
10:46:00 AM: ownloads/1.3.2/yarn-v1.3.2.tar.gz → /tmp/yarn.tar.gz.CnASzwvpRQ
10:46:00 AM: % Total % Received
10:46:00 AM: % Xferd Average Speed Time Time Time Current
10:46:00 AM: Dload Up
10:46:00 AM: load Total Spent Left Sp
10:46:00 AM: eed
10:46:00 AM:
0 0 0
10:46:00 AM: 0 0 0 0 0 --:–:-- –
10:46:00 AM: :–:-- --:–:-- 0
10:46:00 AM:
100 77 100 77 0 0 603 0 --:–:-- --:–:-- --:–:–
10:46:00 AM: 606
10:46:01 AM:
100 91 100 91 0 0 227 0 –
10:46:01 AM: :–:-- --:–:-- --:–:-- 227
10:46:01 AM:
100 624 100 624 0 0 1026 0 --:–:-- --:–:
10:46:01 AM: – --:–:-- 1026
10:46:01 AM:
100 865k 100 865k 0 0 1127k 0 --:–:-- --:–:-- --:–:-- 1127k
10:46:01 AM: [2/2]: https://yar
10:46:01 AM: npkg.com/downloads/1.3.2/yarn-v1.3.2.tar.gz.asc → /tmp/y
10:46:01 AM: arn.tar.gz.CnASzwvpRQ.asc
10:46:01 AM:
100 81 100 81 0
10:46:01 AM: 0 1152 0 --:–:-- --:–:-- --:–:-- 1152
10:46:01 AM:
100 95 100 95
10:46:01 AM: 0 0 967 0 --:–:-- --:–:-- --:–:-- 967
10:46:01 AM:
0 0 0 0 0 0 0
10:46:01 AM: 0 --:–:-- --:–:-- --:–:-- 0
100 628 100 628 0 0 29
10:46:01 AM: 89 0 --:–:-- --:–:-- --:–:-- 613k
10:46:01 AM:
100 1027 100 1027 0
10:46:01 AM: 0 3921 0 --:–:-- --:–:-- --:–:-- 3921
10:46:01 AM: > Verifying integrity…
10:46:01 AM: gpg: Signature made Thu 02 Nov 2017 04:44:10 PM UTC using RSA key ID FD2497F5
10:46:01 AM: gpg: Good signature from “Yarn Packaging <>”
10:46:01 AM: gpg: Note: This key has expired!
10:46:01 AM: Primary key fingerprint:
10:46:01 AM: 72EC F46A 56B4 AD39 C907 BBB7 1646 B01B 86E5 0310
10:46:01 AM: Subkey fingerprint: 6A01 0C51 6600 6599 AA17 F081 46C2 130D FD24 97F5
10:46:01 AM: > GPG signature looks good
10:46:01 AM: > Extracting to ~/.yarn…
10:46:01 AM: > Adding to $PATH…
10:46:01 AM: > We’ve added the following to your /opt/buildhome/.profile
10:46:01 AM: > If this isn’t the profile of your current shell then please add the following to your correct profile:
10:46:01 AM: export PATH="$HOME/.yarn/bin:$HOME/.config/yarn/global/node_modules/.bin:$PATH"
10:46:01 AM:
10:46:02 AM: > Successfully installed Yarn 1.3.2! Please open another terminal where the yarn command will now be available.
10:46:02 AM: Installing NPM modules using Yarn version 1.3.2
10:46:03 AM: yarn install v1.3.2
10:46:03 AM: [1/4] Resolving packages…
10:46:04 AM: [2/4] Fetching packages…
10:46:14 AM: info fsevents@1.2.4: The platform “linux” is incompatible with this module.
10:46:14 AM: info “fsevents@1.2.4” is an optional dependency and failed compatibility check. Excluding it from installation.
10:46:14 AM: [3/4] Linking dependencies…
10:46:14 AM: warning “nuxt > file-loader > schema-utils > ajv-errors@1.0.0” has unmet peer dependency “ajv@>=5.0.0”.
10:46:14 AM: warning " > sass-loader@7.1.0" has unmet peer dependency “webpack@^3.0.0 || ^4.0.0”.
10:46:14 AM: warning “vue-social-sharing > rollup-plugin-json@2.3.1” has unmet peer dependency “rollup@< 0.59.0”.
10:46:18 AM: [4/4] Building fresh packages…
10:46:20 AM: success Saved lockfile.
10:46:20 AM: Done in 16.84s.
10:46:20 AM: NPM modules installed using Yarn
10:46:20 AM: Started restoring cached go cache
10:46:20 AM: Finished restoring cached go cache
10:46:20 AM: Installing Go version 1.10
10:46:26 AM: unset GOOS;
10:46:26 AM: unset GOARCH;
10:46:26 AM: export GOROOT=’/opt/buildhome/.gimme_cache/versions/go1.10.linux.amd64’;
10:46:26 AM: export PATH="/opt/buildhome/.gimme_cache/versions/go1.10.linux.amd64/bin:${PATH}";
10:46:26 AM: go version >&2;
10:46:26 AM: export GIMME_ENV="/opt/buildhome/.gimme_cache/env/go1.10.linux.amd64.env"
10:46:26 AM: go version go1.10 linux/amd64
10:46:26 AM: Installing missing commands
10:46:26 AM: Verify run directory
10:46:26 AM: Executing user command: yarn run generate
10:46:26 AM: yarn run v1.3.2
10:46:26 AM: $ nuxt generate
10:46:28 AM: [05:16:28] Building project
10:46:28 AM: [05:16:28] Builder initialized
10:46:28 AM: [05:16:28] Nuxt files generated
10:46:28 AM: [05:16:28] Compiling client
10:46:42 AM: [05:16:42] Compiled client in 14s
10:46:42 AM: Hash: e9ff3bbc356b2689b5c6
10:46:42 AM: Version: webpack 4.25.1
10:46:42 AM: Time: 13914ms
10:46:42 AM: Built at: 2021-08-17 05:16:42
10:46:42 AM: Asset Size Chunks Chunk Names
10:46:42 AM: 276af20b8048254fba7f.js 9.46 KiB 4 [emitted] pages/posts/index
10:46:42 AM: 3fe8d7e089e03d7bd0f4.js 2.22 KiB 5 [emitted] runtime
10:46:42 AM: 53d245f711daf6ff9770.js 8.62 KiB 2 [emitted] pages/index
10:46:42 AM: 5f55154f7ae8eddf1923.js 11.2 KiB 3 [emitted] pages/posts/_slug
10:46:42 AM: LICENSES 706 bytes [emitted]
10:46:42 AM: bceb6c4273e2b0539afe.js 157 KiB 1 [emitted] commons.app
10:46:42 AM: c9202a3cbb554c5fa83a.js 471 KiB 0 [emitted] [big] app
10:46:42 AM: + 3 hidden assets
10:46:42 AM: Entrypoint app = 3fe8d7e089e03d7bd0f4.js bceb6c4273e2b0539afe.js c9202a3cbb554c5fa83a.js
10:46:42 AM: WARNING in asset size limit: The following asset(s) exceed the recommended size limit (244 KiB).
10:46:42 AM: This can impact web performance.
10:46:42 AM: Assets:
10:46:42 AM: c9202a3cbb554c5fa83a.js (471 KiB)
10:46:42 AM: [05:16:42] Compiling server
10:46:45 AM: [05:16:45] Compiled server in 3s
10:46:45 AM: Hash: e0758b6ab3249f82b6d0
10:46:45 AM: Version: webpack 4.25.1
10:46:45 AM: Time: 2860ms
10:46:45 AM: Built at: 2021-08-17 05:16:45
10:46:45 AM: Asset Size Chunks Chunk Names
10:46:45 AM: server-bundle.json 1.34 MiB [emitted]
10:46:45 AM: Entrypoint app = server-bundle.js
10:46:45 AM: [05:16:45] Could not resolve routes
10:46:45 AM: [05:16:45] Error: write EPROTO 140546426259328:error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure:…/deps/openssl/openssl/ssl/s23_clnt.c:802:
10:46:45 AM: at WriteWrap.afterWrite [as oncomplete] (net.js:868:14)
10:46:45 AM: Nuxt Fatal Error :frowning:
10:46:45 AM: error Command failed with exit code 1.
10:46:45 AM: info Visit yarn run | Yarn for documentation about this command.
10:46:45 AM: Skipping functions preparation step: no functions directory set
10:46:45 AM: Caching artifacts
10:46:45 AM: Started saving node modules
10:46:45 AM: Finished saving node modules
10:46:45 AM: Started saving yarn cache
10:46:45 AM: Finished saving yarn cache
10:46:45 AM: Started saving pip cache
10:46:45 AM: Finished saving pip cache
10:46:45 AM: Started saving emacs cask dependencies
10:46:45 AM: Finished saving emacs cask dependencies
10:46:45 AM: Started saving maven dependencies
10:46:45 AM: Finished saving maven dependencies
10:46:45 AM: Started saving boot dependencies
10:46:45 AM: Finished saving boot dependencies
10:46:45 AM: Started saving go dependencies
10:46:46 AM: Finished saving go dependencies
10:46:49 AM: Error running command: Build script returned non-zero exit code: 1
10:46:49 AM: Failing build: Failed to build site
10:46:49 AM: failed during stage ‘building site’: Build script returned non-zero exit code: 1
10:46:49 AM: Finished processing build request in 56.320715974s

Project is linked with bitbucket:

Repo: Log in with Atlassian account

This error seems related to https - How to fix SSL wrong version number error in NuxtJS? - Stack Overflow.

You also need to change your build image as per Please read! End of support for Trusty build image: Everything you need to know

Your repository is private.

hello @coelmay , I have already tried this. But still same.

see, this was with new image: Screenshot by Lightshot

After changing image there is new issue along with previous. I am not sure why this is happening here, when it is working fine on my local.

2:54:46 PM: $ yarn run generate
2:54:46 PM: yarn run v1.3.2
2:54:46 PM: $ nuxt generate
2:55:04 PM: [09:25:04] Could not resolve routes
2:55:04 PM: [09:25:04] Error: write EPROTO 140034072708928:error:14077410:SSL routines:SSL23_GET_SERVER_HELLO:sslv3 alert handshake failure:…/deps/openssl/openssl/ssl/s23_clnt.c:802:
2:55:04 PM: at WriteWrap.afterWrite [as oncomplete] (net.js:868:14)
2:55:04 PM: Nuxt Fatal Error :frowning:
2:55:04 PM: error Command failed with exit code 1.
2:55:04 PM: info Visit yarnpkg . com/en/docs/cli/run for documentation about this command.
2:55:04 PM: ​
2:55:04 PM: ────────────────────────────────────────────────────────────────
2:55:04 PM: “build.command” failed
2:55:04 PM: ────────────────────────────────────────────────────────────────
2:55:04 PM: ​
2:55:04 PM: Error message
2:55:04 PM: Command failed with exit code 1: yarn run generate
2:55:04 PM: ​
2:55:04 PM: Error location
2:55:04 PM: In Build command from Netlify app:
2:55:04 PM: yarn run generate
2:55:04 PM: ​
2:55:04 PM: Resolved config
2:55:04 PM: build:
2:55:04 PM: command: yarn run generate
2:55:04 PM: commandOrigin: ui
2:55:04 PM: environment:
2:55:04 PM: - NETLIFY_BUILD_DEBUG
2:55:04 PM: publish: /opt/build/repo/dist
2:55:04 PM: publishOrigin: ui

I’ve never seen an error like this when building NuxtJS. As I don’t know the the particulars of your app configuration, build setup, and so on, I can offer no definitive answer of resolution.

Should I send you my config files here?

And if yes please mention which file I need to send?

Nuxt usually needs the following build command nuxt build && nuxt generate. When you run only nuxt generate, I’m not sure if that’s supported. Maybe you need to change your generate command in package.json to match the above.

If that’s not helping, you’d have to share your repo. The one you’ve shared is private and thus, cannot be accessed by us. If you could make it public, that would help.

it is already “nuxt generate” in package.json file.

Let me send you access in a while.