Home
Support Forums

Build Fail with incompatible module

My site is failing build with a incompatible module. This is the first time I have experienced this. I looked through my package.json and it doesnt live in there.

Site name: https://airlines-staging.netlify.app

LOG:

5:10:22 PM: Build ready to start
5:10:25 PM: build-image version: fd3b56fcdbaad56e70919e8a4b2da9b411ec3532 (xenial)
5:10:25 PM: build-image tag: v3.10.1
5:10:25 PM: buildbot version: 0e1298c157b10f24ae5c9a9af08df22d0babb90a
5:10:25 PM: Building without cache
5:10:25 PM: Starting to prepare the repo for build
5:10:26 PM: No cached dependencies found. Cloning fresh repo
5:10:26 PM: git clone git@bitbucket.org:nomadwebdev/advanced-airlines-development
5:10:27 PM: Preparing Git Reference refs/heads/staging
5:10:28 PM: Parsing package.json dependencies
5:10:29 PM: Different functions path detected, going to use the one specified in the Netlify configuration file: ‘functions’ versus ‘’ in the Netlify UI
5:10:29 PM: Starting build script
5:10:29 PM: Installing dependencies
5:10:29 PM: Python version set to 2.7
5:10:30 PM: v12.18.0 is already installed.
5:10:31 PM: Now using node v12.18.0 (npm v6.14.4)
5:10:31 PM: Started restoring cached build plugins
5:10:31 PM: Finished restoring cached build plugins
5:10:31 PM: Attempting ruby version 2.7.1, read from environment
5:10:32 PM: Required ruby-2.7.1 is not installed - installing.
5:10:32 PM: Searching for binary rubies, this might take some time.
5:10:33 PM: Found remote file https://rvm_io.global.ssl.fastly.net/binaries/ubuntu/16.04/x86_64/ruby-2.7.1.tar.bz2
5:10:33 PM: Checking requirements for ubuntu.
5:10:33 PM: Requirements installation successful.
5:10:33 PM: ruby-2.7.1 - #configure
5:10:33 PM: ruby-2.7.1 - #download
5:10:34 PM: ruby-2.7.1 - #validate archive
5:10:38 PM: ruby-2.7.1 - #extract
5:10:41 PM: ruby-2.7.1 - #validate binary
5:10:41 PM: ruby-2.7.1 - #setup
5:10:42 PM: ruby-2.7.1 - #gemset created /opt/buildhome/.rvm/gems/ruby-2.7.1@global
5:10:42 PM: ruby-2.7.1 - #importing gemset /opt/buildhome/.rvm/gemsets/global.gems…
5:10:43 PM: ruby-2.7.1 - #generating global wrappers…
5:10:43 PM: ruby-2.7.1 - #gemset created /opt/buildhome/.rvm/gems/ruby-2.7.1
5:10:43 PM: ruby-2.7.1 - #importing gemsetfile /opt/buildhome/.rvm/gemsets/default.gems evaluated to empty gem list
5:10:43 PM: ruby-2.7.1 - #generating default wrappers…
5:10:44 PM: Using /opt/buildhome/.rvm/gems/ruby-2.7.1
5:10:44 PM: Using ruby version 2.7.1
5:10:44 PM: Using PHP version 5.6
5:10:44 PM: Started restoring cached yarn cache
5:10:44 PM: Finished restoring cached yarn cache
5:10:45 PM: Found yarn version (1.22.10) that doesn’t match expected (1.22.4)up to date in 0.029s
5:10:45 PM: Installing yarn at version 1.22.4
5:10:45 PM: Installing Yarn!
5:10:45 PM: > Downloading tarball…
5:10:46 PM: [1/2]: https://yarnpkg.com/downloads/1.22.4/yarn-v1.22.4.tar.gz → /tmp/yarn.tar.gz.Pr2nxbOm2Y
5:10:46 PM: % Total % Received % Xferd Average Speed Time Time Time Current
5:10:46 PM: Dload Upload Total Spent Left Speed
5:10:46 PM: 0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0
5:10:46 PM: 100 79 100 79 0 0 304 0 --:–:-- --:–:-- --:–:-- 305
5:10:46 PM: 100 93 100 93 0 0 133 0 --:–:-- --:–:-- --:–:-- 133
5:10:46 PM: 0 0 0 0 0 0 0 0 --:–:-- --:–:-- --:–:-- 0
5:10:46 PM: 100 625 100 625 0 0 658 0 --:–:-- --:–:-- --:–:-- 16025
5:10:47 PM: 100 1215k 100 1215k 0 0 1060k 0 0:00:01 0:00:01 --:–:-- 1060k
5:10:47 PM: [2/2]: https://yarnpkg.com/downloads/1.22.4/yarn-v1.22.4.tar.gz.asc → /tmp/yarn.tar.gz.Pr2nxbOm2Y.asc
5:10:47 PM: 100 83 100 83 0 0 845 0 --:–:-- --:–:-- --:–:-- 845
5:10:47 PM: 100 97 100 97 0 0 768 0 --:–:-- --:–:-- --:–:-- 768
5:10:47 PM: 100 629 100 629 0 0 4091 0 --:–:-- --:–:-- --:–:-- 4091
5:10:47 PM: 100 1028 100 1028 0 0 6201 0 --:–:-- --:–:-- --:–:-- 6201
5:10:47 PM: > Verifying integrity…
5:10:47 PM: gpg: Signature made Mon 09 Mar 2020 03:52:13 PM UTC using RSA key ID 69475BAA
5:10:47 PM: gpg: Good signature from “Yarn Packaging yarn@dan.cx
5:10:47 PM: gpg: WARNING: This key is not certified with a trusted signature!
5:10:47 PM: gpg: There is no indication that the signature belongs to the owner.
5:10:47 PM: Primary key fingerprint: 72EC F46A 56B4 AD39 C907 BBB7 1646 B01B 86E5 0310
5:10:47 PM: Subkey fingerprint: 6D98 490C 6F1A CDDD 448E 4595 4F77 6793 6947 5BAA
5:10:47 PM: > GPG signature looks good
5:10:47 PM: > Extracting to ~/.yarn…
5:10:47 PM: > Adding to $PATH…
5:10:47 PM: > Successfully installed Yarn 1.22.4! Please open another terminal where the yarn command will now be available.
5:10:48 PM: No yarn workspaces detected
5:10:48 PM: Started restoring cached node modules
5:10:48 PM: Finished restoring cached node modules
5:10:48 PM: Installing NPM modules using Yarn version 1.22.4
5:10:48 PM: yarn install v1.22.4
5:10:49 PM: [1/4] Resolving packages…
5:10:49 PM: [2/4] Fetching packages…
5:11:00 PM: warning url-loader@1.1.2: Invalid bin field for “url-loader”.
5:11:22 PM: info fsevents@2.3.2: The platform “linux” is incompatible with this module.
5:11:23 PM: Creating deploy upload records
5:11:22 PM: info “fsevents@2.3.2” is an optional dependency and failed compatibility check. Excluding it from installation.
5:11:23 PM: Failed during stage ‘building site’: Build script returned non-zero exit code: 1
5:11:22 PM: error type-fest@2.5.3: The engine “node” is incompatible with this module. Expected version “>=12.20”. Got “12.18.0”
5:11:22 PM: error Found incompatible module.
5:11:22 PM: info Visit yarn install | Yarn for documentation about this command.
5:11:22 PM: Error during Yarn install
5:11:22 PM: Build was terminated: Build script returned non-zero exit code: 1
5:11:23 PM: Failing build: Failed to build site
5:11:24 PM: Finished processing build request in 58.600423513s

Hi @nomadWebdev

Based on this line in the log, the version of node you are using is incompatible. You need to change the version of node.js you are using to v12.20 or higher.

So mad I misunderstood that. Thanks for the help!