Build exceeded maximum allowed runtime - Nuxt

Hello support,
I have been having problems with site deployment for a couple of days now. Yesterday the deployment was successful after a couple of attempts, while today it is not working anymore.

The site is:
myswimlook.netlify.app

Repository (public)

Build log:

2:19:23 PM: Build ready to start
2:19:28 PM: build-image version: d7b3dbfb0846505993c9a131894d1858074c90b4 (focal)
2:19:28 PM: build-image tag: v4.10.1
2:19:28 PM: buildbot version: 1c362ef848ac5e35535bdb572ebca893db28c8a0
2:19:28 PM: Building without cache
2:19:28 PM: Starting to prepare the repo for build
2:19:28 PM: No cached dependencies found. Cloning fresh repo
2:19:28 PM: git clone https://github.com/filipposwift/myswimlook
2:19:29 PM: Preparing Git Reference refs/heads/master
2:19:29 PM: Parsing package.json dependencies
2:19:30 PM: Starting build script
2:19:30 PM: Installing dependencies
2:19:30 PM: Python version set to 2.7
2:19:31 PM: Downloading and installing node v16.17.0...
2:19:31 PM: Downloading https://nodejs.org/dist/v16.17.0/node-v16.17.0-linux-x64.tar.xz...
2:19:31 PM: Computing checksum with sha256sum
2:19:31 PM: Checksums matched!
2:19:33 PM: Now using node v16.17.0 (npm v8.15.0)
2:19:33 PM: Started restoring cached build plugins
2:19:33 PM: Finished restoring cached build plugins
2:19:33 PM: Attempting ruby version 2.7.2, read from environment
2:19:34 PM: Using ruby version 2.7.2
2:19:34 PM: Using PHP version 8.0
2:19:34 PM: Started restoring cached yarn cache
2:19:34 PM: Finished restoring cached yarn cache
2:19:34 PM: No yarn workspaces detected
2:19:34 PM: Started restoring cached node modules
2:19:34 PM: Finished restoring cached node modules
2:19:35 PM: Installing NPM modules using Yarn version 1.22.10
2:19:35 PM: npm WARN config tmp This setting is no longer used.  npm stores temporary files in a special
2:19:35 PM: npm WARN config location in the cache, and they are managed by
2:19:35 PM: npm WARN config     [`cacache`](http://npm.im/cacache).
2:19:35 PM: yarn install v1.22.10
2:19:35 PM: [1/4] Resolving packages...
2:19:35 PM: [2/4] Fetching packages...
2:19:49 PM: info fsevents@2.3.2: The platform "linux" is incompatible with this module.
2:19:49 PM: info "fsevents@2.3.2" is an optional dependency and failed compatibility check. Excluding it from installation.
2:19:49 PM: info fsevents@1.2.13: The platform "linux" is incompatible with this module.
2:19:49 PM: info "fsevents@1.2.13" is an optional dependency and failed compatibility check. Excluding it from installation.
2:19:49 PM: [3/4] Linking dependencies...
2:19:49 PM: warning "nuxt > @nuxt/components@2.2.1" has unmet peer dependency "consola@*".
2:19:49 PM: warning " > @babel/eslint-parser@7.17.0" has unmet peer dependency "@babel/core@>=7.11.0".
2:19:49 PM: warning "@nuxtjs/eslint-config > eslint-config-standard@16.0.3" has incorrect peer dependency "eslint@^7.12.1".
2:19:49 PM: warning "@nuxtjs/eslint-config > eslint-plugin-promise@5.2.0" has incorrect peer dependency "eslint@^7.0.0".
2:19:49 PM: warning "@nuxtjs/svg > svg-sprite-loader > svg-baker > postcss-prefix-selector@1.14.0" has incorrect peer dependency "postcss@7.x || 8.x".
2:19:55 PM: [4/4] Building fresh packages...
2:19:59 PM: Done in 24.23s.
2:19:59 PM: NPM modules installed using Yarn
2:19:59 PM: Started restoring cached go cache
2:19:59 PM: Finished restoring cached go cache
2:19:59 PM: Installing Go version 1.16.5 (requested 1.16.5)
2:20:03 PM: unset GOOS;
2:20:03 PM: unset GOARCH;
2:20:03 PM: export GOROOT='/opt/buildhome/.gimme/versions/go1.16.5.linux.amd64';
2:20:03 PM: export PATH="/opt/buildhome/.gimme/versions/go1.16.5.linux.amd64/bin:${PATH}";
2:20:03 PM: go version >&2;
2:20:03 PM: export GIMME_ENV="/opt/buildhome/.gimme/env/go1.16.5.linux.amd64.env"
2:20:03 PM: go version go1.16.5 linux/amd64
2:20:03 PM: Installing missing commands
2:20:03 PM: Verify run directory
2:20:04 PM: ​
2:20:04 PM: ────────────────────────────────────────────────────────────────
2:20:04 PM:   Netlify Build                                                 
2:20:04 PM: ────────────────────────────────────────────────────────────────
2:20:04 PM: ​
2:20:04 PM: ❯ Version
2:20:04 PM:   @netlify/build 27.18.4
2:20:04 PM: ​
2:20:04 PM: ❯ Flags
2:20:04 PM:   baseRelDir: true
2:20:04 PM:   buildId: 632c52cb2d9a4f1d3422bd2c
2:20:04 PM:   deployId: 632c52cb2d9a4f1d3422bd2e
2:20:04 PM: ​
2:20:04 PM: ❯ Current directory
2:20:04 PM:   /opt/build/repo
2:20:04 PM: ​
2:20:04 PM: ❯ Config file
2:20:04 PM:   No config file was defined: using default values.
2:20:04 PM: ​
2:20:04 PM: ❯ Context
2:20:04 PM:   production
2:20:05 PM: ​
2:20:05 PM: ❯ Installing plugins
2:20:05 PM:    - netlify-plugin-inline-critical-css@2.0.0
2:20:05 PM:    - @netlify/plugin-lighthouse@3.4.1
2:20:23 PM: ​
2:20:23 PM: ❯ Loading plugins
2:20:23 PM:    - netlify-plugin-inline-critical-css@2.0.0 from Netlify app
2:20:23 PM:    - @netlify/plugin-lighthouse@3.4.1 from Netlify app
2:20:24 PM: ​
2:20:24 PM: ────────────────────────────────────────────────────────────────
2:20:24 PM:   1. Build command from Netlify app                             
2:20:24 PM: ────────────────────────────────────────────────────────────────
2:20:24 PM: ​
2:20:24 PM: $ yarn generate -m
2:20:25 PM: yarn run v1.22.10
2:20:25 PM: $ nuxt generate -m
2:55:24 PM: Build exceeded maximum allowed runtime

Build Settings:

Solved! I honestly still don’t know what the problem was, I created a new repository and did the whole process all over again. I don’t know what was broken in the previous one, I couldn’t find out.

1 Like

Thanks for following up and letting us know! I am glad you are unblocked now.