Build crash with latest netlify version

Hello,

this build Netlify App is failing with newest netlify cli locally and through netlify web app.

netlify version locally is :

ā–¶ netlify --version
netlify-cli/11.8.1 darwin-x64 node-v16.9.1

error is :

Error: Cannot find module 'pages/index.js'

It seems that the require('absolute/path') is not working correctly anymore.

Edit:
if i rebuild without changing anything it seems to work again so maybe I broke something (Netlify App)

Edit:

Locally (using netlify dev) it seems to build but I am getting this error in the terminal:

ā—ˆ Loaded edge function next-dev
error: Found argument '--no-config' which wasn't expected, or isn't valid in this context

        If you tried to supply `--no-config` as a value rather than a flag, use `-- --no-config`

USAGE:
    deno run --allow-all --unstable --import-map <FILE> --v8-flags=<v8-flags> <SCRIPT_ARG>...

For more information try --help

ā—ˆ Failed reloading edge function
ā—ˆ Reloading edge functions...
error: Found argument '--no-config' which wasn't expected, or isn't valid in this context

        If you tried to supply `--no-config` as a value rather than a flag, use `-- --no-config`

USAGE:
    deno run --allow-all --unstable --import-map <FILE> --v8-flags=<v8-flags> <SCRIPT_ARG>...

For more information try --help

ā—ˆ Failed reloading edge function

and this in the browser:

There was an error with an Edge Function. Please check the terminal for more details.

I believe that this may have been caused by an issue in the Netlify CLI v11.8.1 which released yesterday.
v11.8.2 released today with a fix. Hopefully that might address the issue.

Try updating your Netlify CLI with npm i -g netlify-cli

2 Likes

it works now, thanks

2 Likes