Build commands no longer being skipped?

Not sure if this is a new bug, but are build commands no longer being skipped if the field is empty? I want to deploy my site without a build command, and it has worked every time in the past, but today it started forcing a build command and erroring out without deploying.

Anyone else run into this issue?

Seems I am running into the same issue.

Seems like a bug to me as no build command is set (neither in package.json nor in netlify settings)

Previous logs (successful deploy, No build command found, continuing to publishing):

3:26:28 PM: Build ready to start
3:26:30 PM: build-image version: 6dfe19d15f524c85d6f9bf7df9fb30b0a9f0a61a
3:26:30 PM: build-image tag: v3.3.10
3:26:30 PM: buildbot version: 0d19834c19ebfe54208907d729718495339fe085
3:26:31 PM: Fetching cached dependencies
3:26:31 PM: Starting to download cache of 25.6MB
3:26:31 PM: Finished downloading cache in 247.571331ms
3:26:31 PM: Starting to extract cache
3:26:32 PM: Finished extracting cache in 604.728181ms
3:26:32 PM: Finished fetching cache in 860.252347ms
3:26:32 PM: Starting to prepare the repo for build
3:26:32 PM: Preparing Git Reference refs/heads/master
3:26:34 PM: No build command found, continuing to publishing
3:26:34 PM: Starting to deploy site from ‘/’
3:26:34 PM: Creating deploy tree asynchronously
3:26:35 PM: Creating deploy upload records
3:27:05 PM: 30 new files to upload
3:27:05 PM: 0 new functions to upload
3:27:12 PM: Finished processing build request in 42.004118537s
3:27:25 PM: Starting post processing
3:28:20 PM: Post processing done
3:28:20 PM: Site is live

Now (deploy fails as I don’t want to fetch dependencies and all)

9:59:47 AM: Build ready to start
9:59:48 AM: build-image version: 30f629161c0736b1a3ecd8b418e5eeffab5c0faf
9:59:48 AM: build-image tag: v3.3.14
9:59:48 AM: buildbot version: 1da4cf38e1ad1fe9ce7deeeba939bcc9c6c3f794
9:59:49 AM: Fetching cached dependencies
9:59:49 AM: Starting to download cache of 26.3MB
9:59:50 AM: Finished downloading cache in 1.05274713s
9:59:50 AM: Starting to extract cache
9:59:50 AM: Finished extracting cache in 626.35292ms
9:59:50 AM: Finished fetching cache in 1.685692618s
9:59:50 AM: Starting to prepare the repo for build
9:59:51 AM: Preparing Git Reference refs/heads/master
9:59:53 AM: Starting build script
9:59:53 AM: Installing dependencies
9:59:55 AM: v10.20.1 is already installed.
9:59:55 AM: Now using node v10.20.1 (npm v6.14.4)
… loading dependencies, npm install …

Same issue here, I need to skip the build command but it is always called. Tried to unset it again and even created an empty script in my project (in package.json, echo: ‘’), no luck.

As a result, all our deployments are frozen for now.

I am not seeing this problem. Here is the deploy log for a deploy with no build command, neither in the app settings nor in netlify.toml:

@william - in your logs:
5:18:35 PM: Starting build script

used to be
3:26:34 PM: No build command found, continuing to publishing

Is your build log public, @christophe? Can you post the link? In the excerpt that you posted there is no message about the build failing.

The deploy will fail if you have any local dependencies though. Either way, something is clearly wrong that the build scripts are not being skipped.

Hey @william, sure and thanks.

last successful (exactly same settings):

also on another repo:



Whatever changed on Netlify’s end, the deployment is detecting package.json in your repo and attempting to run npm install even before it checks for your build command.

Hopefully someone from Netlify can investigate and fix the problem.

I opened an issue here:

Thanks for the help @william

In the mean time I wonder if deleting package.json will help.

If deleting package.json is an option for you I would try that. You should also delete bower.json because the presence of that file also triggers dependency installation.

Hi everyone,

We are working on a fix for this problem:
We will reach out as soon as this is fixed.
Thanks for raising this issue and helping out with the build logs!

1 Like

Thanks for reporting this @dle1. We released a fix that reinstates the old behavior of skipping straight to deploy if no build command or build plugins are present. Could you please confirm that it’s working for you?


Thanks a lot for the resolution and @william for having submitted a bug report.

Works back for me:

1 Like

It works now! Thank you so much for the fix!

1 Like