Branch deploys not working

I have tried twice to deploy a branch for a site.
The settings are set to all branches to deploy.

two tries app Ids: 509c82bd-9715-420c-b51e-aee7ae9dbac8
5aedd103-e280-4c48-953d-75a34e9b1bc9

I tried resetting the site by creating a new one and the branch is there on github and update. Netlify does not deploy.

Branch is called “not-static”

I can access it via not-static–webistename but not in netlify UI

Hi, @AaronP. I see deploys for that branch here:

https://app.netlify.com/sites/cocky-pasteur-345a6f/deploys

For example, this deploy:

https://app.netlify.com/sites/cocky-pasteur-345a6f/deploys/5f8f10e2e023eb00079b42e8

Also, the branch name subdomain is working as well:

https://not-static–cocky-pasteur-345a6f.netlify.app/

In short, it is working from what I can see. If the issue still is not resolved, please let us know.

The branches must be working on the backend, but the UI is not reflecting it?
See below, there are no deploy previews, I am pretty sure all my previous branch deploys showed up as a preview here rather than requiring going to deploys and viewing them? Thanks!

Hi, @AaronP, the deploy preview panel is specifically making this API call:

https://api.netlify.com/api/v1/sites/<SITE-API-ID-HERE>/deploys?page=1&per_page=15&deploy-previews=true

This hasn’t changed in the last several years and this only shows deploys which are specific to a PR. This site has branch deploys but it does not have any “deploy previews” for PRs. Some of your sites do have deploy previews but this site does not yet.

https://app.netlify.com/sites/cocky-pasteur-345a6f/deploys?filter=deploy%20previews

If there are other questions about this, please let us know.

Ah yes, this is my mistake. In my other sites I setup another branch and had pull requests to it rather than directly commit to it. Thanks!

1 Like