Bought a domain, connected it, and now its saying "page not found"

ive been trying to get my github for this website to show up with the domain name that I purchased. Every time I click the link, it shows me that the site cant be seen

github - GitHub - JustSpokenCodes/crownyourrights: An app for all to know the talents of BeNice

Hi there,

Did you see this guide yet? This is the best place to start for “Page Not Found” issues.

If you are still seeing issues after following the troubleshooting steps in this guide, please let us know!

tried all three of those things and its still not showing. Thank you for the link. Maybe my directory is wrong or the build command is wrong…im still confued

yes, i think double checking those settings is a good first move.

you would also want to check and see if your deploy went off without a hitch. if for some reason your project didn’t actually build and deploy, then you might see that page as well!

This Common Issue contains a ton of useful debugging tips that can likely help you solve your problem :slight_smile:

If you are still having problems, please do link us to a failed deploy (or paste the entire log here) and we’ll try and troubleshoot.

10:16:57 PM: Build ready to start
10:16:59 PM: build-image version: 2dbd444fcdce00cf06325060a8238d5ae3e86774
10:16:59 PM: build-image tag: v3.3.7
10:16:59 PM: buildbot version: 10926ec3478dd6c0bfc84e15d24de329bb1b357f
10:17:00 PM: Fetching cached dependencies
10:17:00 PM: Starting to download cache of 408.7KB
10:17:00 PM: Finished downloading cache in 79.505408ms
10:17:00 PM: Starting to extract cache
10:17:00 PM: Finished extracting cache in 19.218339ms
10:17:00 PM: Finished fetching cache in 99.43008ms
10:17:00 PM: Starting to prepare the repo for build
10:17:00 PM: Preparing Git Reference refs/heads/master
10:17:01 PM: No build command found, continuing to publishing
10:17:01 PM: Starting to deploy site from ‘/’
10:17:01 PM: Creating deploy tree
10:17:01 PM: Creating deploy upload records
10:17:01 PM: 5 new files to upload
10:17:01 PM: 0 new functions to upload
10:17:01 PM: Starting post processing
10:17:01 PM: Post processing done
10:17:02 PM: Site is live

so what I am noticing here is that there isn’t actually any buildable or publishable content in the root of that directory (just some .md files). You need to be telling our system (by changing the base directory) to go into the “crownyr” subdirectory and build from there, as thats where your package.json and all that live.

hope this helps - try tweaking those settings and i bet things will start behaving better.

and how would I do that? I have changed my base directory to crownyr or do I have to do crownyr/src??

it looks like your base dir should be crownyr
your publish dir should be build, as mentioned here:

and your build command should be yarn build.

give that a try and let us know if that works :+1:

im starting to think my app hates me

thank you greatly for all your help

pls try:

base: crownyr/
build: yarn build
publish: build