Bogus Github LFS file


Site : (no homepage, that’s expected)
Repository : GitHub - mistic100/photo-sphere-viewer-data

The repository contains a bunch of images and video stored on Github LFS. Yesterday I discovered that 3 files weren’t actually on LFS so I migrated them using git lfs import --no-rewrite. Here is the commit

On Netlify side that didn’t worked well, the file available on the site was only the LFS descriptor. So I want the hard route, I deleted the files and recreated them (I also renamed them as there was a typo).

BUT the files on Netlify are still wrong, for example this one, the video doesn’t play and if you download it you will get a 133 bytes LFS descriptor file.

Other files like this one are working, as well as the culprit before I tried this migration.

How to fix this ?
Thank you

(note: I created a similar issue yesterday but deleted it because I though I did actually corrupted the repository, but it’s not the case)


Here’s our guide for troubleshooting this feature: [Support Guide] Troubleshooting your Netlify Large Media Configuration

Have you had a chance to try any of these solutions?

@katrina-r I am not using Netlify Large Media, I am using a standard Github LFS repository as source for deployments (with GIT_LFS_ENABLED env variable). So I don’t think any of the troubleshootings apply.

The reason is I want original files to stay on Github. It worked perfectly until I migrated these three particular files.

Hi, @mistic100. The solution here is the GIT_LFS_FETCH_INCLUDE environment variable listed on this docs page.

I have a post with in-depth instructions found below:

If there are questions after reading that, please let us know.

Thank you @luke it works perfectly

Perhaps *.webm should be added to the default config, like *.webp was added in 2020

edit : waiting merge request add webm to the default fetchinclude by mansona · Pull Request #778 · netlify/build-image · GitHub