Awaiting Netlify DNS seems to be stuck


I’m quite new to all of this, I tried to read a couple of entries with similar issues but I’m still not understanding if this is suppoused to work like this.

Yesterday I bought a domain througth Netlify, the domain is Everything seemed to work fine, I stopped using and started using Today I did two things, first I added some DNS records in order to make my site work with some email forwarding services and then I sent the link to some friends to try my website out. It appears they cannot enter the website and are being greeted with the “dns_probe_finished_nxdomain” error.
Going into the “Domains” section of my site, I see “Awaiting Netlify DNS” on but I remember yesterday that was not there. The other one ( is marked as okay.

Is this normal? It’s been like this for at least 6 hours now.

Hi @tomassexenian welcome to the forums. Propagation can take up to 48 hours. If you still see this error in 2 days please reach back out.

It is to my understanding that it’s pretty uncommon for it to take that long, as I have read in other entries in this forum.
Another thing I noticed, and I think it’s quite strange, it’s that works on my PC but when another person uses their PC on their network then it dosen’t work.

I’m sorry if this it’s not so netlify-related but I’m trying to at least be sure that I didn’t do nothing wrong and all I have to do is wait.
Using DNS Checker - DNS Check Propagation Tool all I get is “not resolved” in every country

Hi @tomassexenian,

Thanks for the update. Visiting is resolving properly for me. Are you still seeing issues?

Yes, on Netlify’s domain management for pandabyte I’m still seeing “Awaiting Netlify DNS” for and " :white_check_mark: Netlify DNS" for
If I access any on those links on my PC, it resolves the link just fine. But when, for example, I try to acces any of those links using mobile data or any other network that’s not my home, I get dns_probe_finished_nxdomain.
Does it have something to do with some DNS records I added? I needed them in other to make some email forwarding work.

I can now confirmed that it’s been 48 hours since I purchased the domain but I’m still seeing “Awaiting Netlify DNS” and DNS Checker - DNS Check Propagation Tool throws “Not resolved” for every DNS server.
As I said, everything was fine until I changed some DNS records. All my Domains where marked as " :white_check_mark: Netlify DNS" but after I added some new DNS records, the problem started and have not been resolved

Hi, @tomassexenian. There was an error with the DNS record itself on the Netlify side of things. That error has been fixed now and the DNS record is working.

If there are other questions or concerns, please let us know.