`autoLaunch` in `netlify.toml`

This is a site that is using vite as a local dev server.

Hi. I’m having trouble because autoLaunch in my netlify.toml file is not working as I expect. I understand this should prevent a browser from opening to the local dev server (I have autoLaunch = false).

Another issue is that it opens to the wrong URL. The site is hosted at localhost:8888, but the browser opens to localhost:4173. I wouldn’t mind if the browser opened to the correct URL.

How to get it to open the correct URL?

Hey @nichoth,

It appears to work fine in my tests.

Also, as a workaround, based on the example here: Netlify CLI dev command, you can run:

BROWSER=none netlify dev # disable browser auto opening