Astro prefetch with Netlify leads to errors

The test site is: https://astro-prefetch-test.netlify.app

I’m using an Astro template in which I added prefetch to the top-level links using Astro’s data-astro-prefetch. This is a static site BTW. When I build and preview locally there are no issues with prefetching links.

On the other hand, when using Netlify, it resolves in an error for each link I hover.
Example: (failed) net::ERR_FAILED page.DFwqf4PB.js:1

I tried adding a _headers file with the following, but it made no difference:

/_astro/*
  Cache-Control: public, max-age=31536000
  Content-Type: application/javascript

Is there something I am doing wrong?

I tried hovering over the blog and about link on your website, but didn’t get any errors. Has this been resolved?

Netlify does pretty url optimization by default. My project has links without a trailing slash, but Netlify was expecting a trailing slash to be matched. Therefore, it was considered a redirect, and failed. Although Chrome seems more forgiving, Brave seems more strict. Once I disabled Netlify’s pretty urls option, no more errors Brave!