API deploy failed : "Deploy contains incorrectly encoded paths: "\xCC" from ASCII-8BIT to UTF-8"

Hello,

Deploy failed with API uploading a zip folder, Netlify dashboard shows the following error :
Deploy contains incorrectly encoded paths: "\xCC" from ASCII-8BIT to UTF-8

Deploy logs are empty, and the process “Unpacking archive” seems to hang

Note that I tried to deploy the exact same zip folder via manual deploy (drag & drop), and this time it worked fine.

I also tried to upload via the API an older archive, and it worked fine too.

The website is sparkling-sunflower-be89ed

Thanks :slight_smile:

Could you share the zip, so we can check further?

Hello @hrishikesh
Just sent you a private message with the ZIP file

Thank you!

I’m having the same issue. Any resolutions?

Sorry for the delay. I’ve raised this with the devs to confirm.

Hi @aaron,

Apart from the incorrect encoding you’re seeing in your IDE, the devs also pointed out that, there are some really long file/folder names in: rails/active_storage/representations. Shortening those would also be useful.

Hi there,

Thanks for the answer.

I confirm that my guess was right, the was issue was caused by images having filenames with accents, such as “Capture d’écran 2023-09-06 à 11.42.44” for example.

I made a fix in my side, removed all the accents from the filenames, and now the deploy via API works correctly.

Note that the issue is still present if we don’t remove the accents, via the API. But it works fine when using manual deploy by drag & drop.

So it seems that there is something correcting the encoding when using drag & drop, but not when using the API to deploy.

Regards