When I visit the site at the address: https://socalyrg.com I get a SSL_PROTOCOL_ERROR in both Chrome and Safari as well as my mobile device. If I visit https://www.socalyrg.com it redirects me to https://socalyrg.com and the site functions properly. The DNS is hosted at GoDaddy and I have an A record for socalyrg.com pointing to and CNAME record for www.socalyrg.com pointing to socalyrg.com. I’ve tried removing the domain and readding it, I’ve tried renewing the certificate for the domain, no luck.

I’ve tried switching the primary domain, I’ve rebuilt a new config, updated the SSL cert with LetsEncrypt. I can’t find any other options to try.

This config/site has been working for the past 2 weeks without issue.

Hi @zagnut007

Welcome to the forums

This is incorrect. As stated in the Configure external DNS for a custom domain the CNAME needs to point to the Netlify site e.g wicked-awesome-site.netlify.app.

But why would that affect the Apex domain?

socalyrg.com redirects to www.socalyrg.com which means the latter is the primary domain (see the Netlify Custom Domains settings.)
But www.socalyrg.com has a CNAME record pointing to socalyrg.com.
So in effect it is an infinite loop.

I understand that, but even after the change on the CNAME, the behavior still occurs. I switch to using Netlify’s DNS until I can hear back on an official support request.

I do not see any SSL errors with socalyrg.com or www.socalyrg.com.