Apex Domain Not working But using subdomain with www

I have a custom domain cryptocost.in with https://www.cryptocost.in as the primary domain and https://cryptocost.in as the apex domain. The DNS is external (routed from Cloudflare for www only).

The issue here is that redirection does not work always. I have re-added the domains and updated the SSL but to no avail. I have tried using CNAME & A in Cloudflare as well but the result is the same. I am not sure how to fix this. The redirection should work always. Once it works in a chrome tab it keeps working however using another tab may again give the error.

I have gone through loads of community supports topics but none of the solution is working for me.

Any help would be appreciated.

The name servers for cryptocost.in are Cloudflare name servers

$ dig cryptocost.in NS
cryptocost.in.		4502	IN	NS	guss.ns.cloudflare.com.
cryptocost.in.		4502	IN	NS	olivia.ns.cloudflare.com.

Yet the screenshot says the domain is using Netlfiy DNS which isn’t right.

If you want to use Cloudflare for DNS you need to use external DNS configuration and make sure the records are DNS Only.

If you want to use Netlify DNS you need to delegate the domain to Netlify and change the name servers to those provided by Netlify during this process.

I am using DNS-only records in Cloudflare. I am not sure how to add external DNS configuration because whenever I add the apex domain it automatically picks Netflix DNS.

Did you add the domain via your team Domains page?

Hello

I removed the Domain from the website and readded as per external DNS configuration but I am still facing intermittent errors.

Using DuckDuckGo Browser

I’m not seeing the correct A record configured for cryptocost.in:

% host cryptocost.in    
%

You’ll need to create an A record for cryptocost.in pointing to 75.2.60.5

Added the A record, still facing the same issue.

@ravi_sharma That’s not what I see:

You’re probably just dealing with DNS propagation.