Algolia search plugin with custom domain name, “domain_not_allowed”

I’m trying to use Algolia with my Gatsbyjs Site. I installed the plugin and have an account with Algolia however when I run a new deploy and go into the “Inspector” I get this error?

GET


:orange_circle: Ignored
HTTP
  • HTTP code:

    200

  • Mime-Type:
    text/html
    This page had a canonical URL ( https://azhotshotsvr.com/ ), which was skipped for this reason: “domain_not_allowed”

    Status
    Full URLhttps://master–youthful-borg-78a45f.netlify.app/
    StatusCanonical URL - Not processed
    Additional informationThis page had a canonical URL ( https://azhotshotsvr.com/ ), which was skipped for this reason: “domain_not_allowed”
    Timings
    Discovery6-Oct-2020 at 14:30:48
    Last crawl6-Oct-2020 at 14:30:57
    Crawl duration1s
    HTTP
    Status Code200
    Content-Type
    html
    Content-Length75.8kB

Howdy! Thanks for trying out the algolia plugin!

We took a look at this and it seems to be an issue on Algolia’s end.

First, for the future, you always have the option of informing the plugin author there is a problem by clicking on the link in the UI that looks like this:

report-issue

Second, Algolia is awesome and unlike many contributors who are overworked individuals, they have their very own support department, and a forum like this one. Yay!

If you figure out what the problem is, it would be super awesome if you followed up and posted it here to help out the next person. Good luck!