Home
Support Forums

/admin Page not Found

Site name: https://dreamy-turing-509552.netlify.app
Git Repo: https://github.com/Nathan-BrokenFaders/Jekyll-Netlify2.0

I’ve spent the best part of a day on trying to fix the dreaded ‘Page Not Found’ issue, but unfortunately I’ve not had any luck.
Going by the several other posts in the forums, it seems like that this is an ongoing issue. However, none of the previous solutions mentioned have worked for my project.

I have tried moving the index.html and config.yml file out of the admin folder into the root, but no luck. I have reset the access key, changed the users etc. Again, no hope.
I have even gone to the extremes of deleting the project, repo and website and starting again from scratch. But ultimately end up at the same roadblock.

Any help would be greatly appreciated!
If there’s any more information you need me to provide, please let me know.
Thanks in advance!

Hi there, @Nathan-BrokenFaders :wave:

Welcome to the Netlify Forums! Sorry to hear you are encountering this issue.

Another common cause for this comes from not specifying in the deploy settings which folder to publish. If your project has a build which generates the site to publish, be sure to tell Netlify where to find that directory. Can you confirm that your deploy settings are correct? I did not see you mention checking this in your post above.

In the example below, the “Publish directory” is dist

Find this in your settings at:

https://app.netlify.com/sites/{YOUR_SITE}/settings/deploys#continuous-deployment

Let us know if this helps! :slight_smile:

Hi Lucy,
Thank you for the quick response :slight_smile:
So my deploy settings are:
Repository github.com/Nathan-BrokenFaders/Jekyll-Netlify2.0

Base directory: Not set

Build command: bundle exec jekyll build

Publish directory: _site

Deploy log visibility: Logs are public

Builds: Active

I’ll admit, all of this was set up automatically so I didn’t think to tamper with it.
Let me know if you spot any obvious issues with it.

howdy @Nathan-BrokenFaders - just want to point out Hillary’s name is, well, Hillary, not Lucy, but hopefully i can help you figure out what isn’t working.

So, first up, your page seems to be loading just fine:

https://dreamy-turing-509552.netlify.app/

all the links you have successfully linked in the top also seem to be loading.

but you are right that the url: https://dreamy-turing-509552.netlify.app/admin/ doesn’t load.

something avout your file structure seems a little off - i see that you wrote in here about 3 hours ago, but your repo shows the last commits 6 and 7 hours ago, respectively.

Have you committed and pushed after making local changes? that might be why things aren’t showing up.

Hi Perry,
Oh god, not sure where I got Lucy from! Apologies for that.
Yeah so I have been committing and pushing frequently, especially before testing out this admin issue.

I have just committed and pushed again this morning, but unfortunately the issue still remains.
I also tried inviting a different user, just in case it was something to do with the log in details.

I’ve taken the liberty of forking your repo and adding it as a site on Netlify. The admin index loads. Maybe try setting up a new site on Netlify?

https://loving-darwin-f90f09.netlify.app/admin/#/

You’re missing the identity widget though, so logging in will be problematic. Add this script tag to the head of your admin page:

<script src="https://identity.netlify.com/v1/netlify-identity-widget.js"></script>

In all fairness: That bit seems to be missing on the jekyll guide documentation page. I’ll get that sorted.

Hi Perry and Tom,
The issue has been resolved.
I asked one of my more experienced peers to look over it. After going through the sitemap and figuring out the admin link looked a bit off, he realised that the index.html file had a space at the beginning of it (embarrassing I know!).

Because of this error on my part, the error messages weren’t displaying which indicated there was some repeated code in my config.yml file which was also throwing it off.

I have now also included the identity widget to the admin file head.
Apologies for taking up your time guys, appreciate the help and effort you put in to solving this.
All the best!

1 Like

It happens! Glad you got things working, happy to help!

1 Like

Not embarrassing at all, thanks so much for coming back and letting us know! I am glad everything is working now. :netliconfetti: