Added subdomain breaks production?

Hi all,

I’ve got a site that was working fine (https and dns) for production, then I added a branch subdomain (for staging) and it works (both https and dns) but the prod url now returns a 404 Not Found and https has broken as well.

Here’s some relevant info:

Netlify domain:
Custom domain: (purchased/managed from

Any advice and/or further debugging suggestions would be greatly appreciated. Thanks!

Hey @anthonygreco

I see Coming Soon when I visit and Is this intended?

I’ve not heard of, nor experienced, a branch deploy breaking a production site. What is the branch? And how should the production site look?

Well that’s extremely peculiar. The Coming Soon, is what I expect on the prod side atm. I just checked in Incognito, as well as my laptop, and a couple other computers and still get the 404, but on my Pixel 6 (even when on the same wireless network :\ ) I get what’s expected. So I guess this is some weird issue with my local network. Any advice? Am I verifying prod on my phone? LOL

If it works as expected on the a different device when connected to the same network, I would look more at the device(s) than the network (slightly annoy that so many devices are needed to test things these days!)

Can you try using your phone as a hotspot for the laptop, and seeing if you get the same result (including in private/incognito windows.) This will (I believe) help determine if the issue is more likely with the device or the network.

Another thing to consider (possibly not now, but as the site develops) is caching as outlined in [Support Guide] Making the most of Netlify's CDN cache

Gatsby for instance uses asset fingerprinted filenames intentionally, which breaks Netlify’s usual caching.

I tested a few other things and in doing so discovered I’m actually seeing the 404 on the NON-www domain. Meaning http?(s):// returns the 404. This seems to be likely to a bad DNS record I have atm. I was reading this article: How to Set Up Netlify DNS - Custom Domains, CNAME, & Records and I think maybe my config isn’t accurate. It doesn’t show once saved if it’s a CNAME or A record etc, so I may just delete them all and try again. This is what I have atm: → → →

The article mentioned I should use the static IP address, and I even recall seeing that at some point, but can’t seem to find it now.

I have the apex automatically redirecting to the www subdomain in all browsers, and using curl (e.g. curl -IL is using Netlify DNS (if it wasn’t branch sub-domains wouldn’t work) so there is nothing to configure in terms of A/CNAME or other DNS records. That article is talking about configuring if using external DNS (e.g. with the domain registrar.)

Well… then I’m at a loss for what is actually going on. :frowning:

It is strange. As I am unable to replicate what you are seeing, it is hard to offer a solution.

Perhaps turn everything off, go for a long walk, and try again :slight_smile:

Well… I guess maybe it just took a while for my local… Seems to be fine this morning. Appreciate your time in assisting.