`action` attribute still shows default netlify page

Hello! I have form:

<form name="contact" method="POST" data-netlify="true" action="/ridiculous-thank-you.html">

When it is submitted, data shows up on the backend, correctly. However, the default Netlify thank you page is shown. Not the page specified in the action attribute.

On the top is the form submission (you can see the URL is what is specified in the form action attribute) and on the bottom is the actual content if you were to type that URL in directly.

The site is using Jekyll. I’ve tried setting the action to include the .html and also without. Same result in both instances.

Any help is greatly appreciated!

Thanks,

-Mike

I verified the behavior you’re describing, very strange indeed.

I noticed that your action in the live environment is converted to a pretty url action="/ridiculous-thank-you". Maybe this is a redirecting issue? Both /ridiculous-thank-you and /ridiculous-thank-you.html seem to exist on your site. Not sure why neither of them is loaded though…

Thanks, I’m just glad I’m not going crazy!

Hey there,
Could you please share the Netlify URL where this form lives, as well as your form code? That’ll help us investigate what’s going on!

@jen https://cleartogo.co/ at the bottom of the homepage

1 Like

I just checked what our backend sees your form action to be and it is… nil. For some reason, our form parser is not picking up the action attribute you set.

Could you please try action="/ridiculous-thank-you" without the .html extension? If that doesn’t work, we may have to try something weird like changing the name of the form so that the new changes are picked up.

> s = Site.find("5037c995-c92d-4d52-a0c2-0068002084d1")
> s.forms[0]
#<Form:0x00007f2dfe0a2700> {
                   :_id => BSON::ObjectId('5e973c93447ea40007ce7d51'),
                :action => nil,
            :created_at => 2020-04-15 16:55:47.797 UTC,
                 :email => nil,
    :explicit_recaptcha => false,
...

Hey Jen, you solved it!

I left the extension as is because I had tried both ways already. But changing the form name worked! Netlify seemed to pick up the action attribute and sent me to the correct page.

Maybe this is a bug with an old form not having an action parameter and then being changed to add it?

1 Like

Now that I’m thinking about this, early on we originally tried to use the recaptcha option but it would never turn on for us. In the end, gave up. That feels like a similar problem to what was reported here.

Yay! Glad to hear you got that working. What you’re saying about the recaptcha is possible, but it’s also possible there was something else going on. Let us know if you’d like to give it another shot and we’ll take a look.