A Let’s Encrypt SSL not working on mobile

Hey there,

I am having an issue with SSL certificate.

I have a few projects on my account and they all seem to be working fine and are fully protected except one.

On one of them for some reason the SSL and padlock is showing only when accessed through desktop browser and not by mobile.

I have tried multiple mobile devices and there is exclamation mark next to address.

I decided to buy separate SSL certificate and install the custom one but this also seems to be not working, when I add a custom one the whole website is not loading as it’s saying the connection is not secured.

Could anyone help me with that, please?

Many thanks.

Can you share the domain name so we can check?

Hi @SamO , sure, please, see the domain below:

Hi @Whitenoise,

I’m unable to replicate an issue, could you show us what you see?

This is what I see on an iPhone.

Hey, @Melvin

Many thanks for looking into that.

I can see you’re using Safari. There should be a padlock if protected with an SSL certificate. Please, try luigirussolo.com

I also use iPhone but on Chrome it’s displayed like this:

I have cleaned all data from the browser but still no luck, however first site, luigirussolo.com is also hosted on Netlify, and it displays completely fine. It looks like SSL is missing when on mobile for some reason.

Any idea what can be causing this? Both sites are made pretty much the same way.


Hi @Whitenoise,

The triangle with an exclamation point in address bar on a mobile browser means there’s elements that are not secure within the code itself. This generally means some elements or assets (such as images) are using http: instead of https:. Found this forum post with a similar issue:

For example, in the dev tools for lunguage.com I see:

For luigirussolo.com, I see the lock pad:

I also don’t see any http:

Hi @Melvin

I was so happy to read your last message at first, as it does make sense. Unfortunately, I was happy too early. I have checked all the lines of code and updated all http to https and the problem still persists.

First, I checked all the files in Visual Studio Code and then used dev tools. I could not find anything with http.

I believe one of the packs I installed in the past (Third Web) is causing that. I decided not to use it at the end but have no idea how to get rid of it. I assume if there is something with http instead https the problem would still occur.

I think I’ll just give up for now. I have no idea how to bite this.

There is always an option to put the whole website back from scratch, but of course, that’s not preferable.

Many thanks for your help @Melvin. I do appreciate it.