Home
Support Forums

A DNS zone for this domain already exists on NS1 when trying to authorize

Hello i am trying to use the netlify dns with my namecheap domain that i just bought but when i try to do so this error is coming A DNS zone for this domain already exists on NS1. the domain i bought is pcgearoid.com and i am the owner of that and i havent hosted it anywhere please check where is the problem occurs and help me Thanks

Hi there, sorry to hear you are having some domain woes :frowning: Give this guide a read through, hopefully it will solve your problem. Let us know if it doesn’t.

Hey Perry I read the article but i cant seem to find manage nameserver anywhere so i can remove that and when i try to add new nameserver it gives error that ns1 already exists i think the problem maybe someone used my domain without actually buying it or maybe it is a bug can you check on that kindly
Thanks

Can someone help me i have sent the support email as well and there is no response there as well i am losing some time because of this as i cant manage to get my domain working with it

The issue has been fixed by support team
Thanks

What support team? I have emailed Name.com about this same issue. I tried removing the dns zone for my domain in name.com but netlify still gives the “A DNS zone for this domain already exists on NS1” error. Has anyone else encountered this recently? Super frustrating!

Hi, @HadenHiles. In order to troubleshoot, we need to know what domain name this is happening for.

In most cases, the issue is that some other company that also uses NS1 has previously created a DNS zone for you at NS1. There cannot be two DNS zone for the same domain name so the creation of the duplicate is failing.

If this is the root cause, then the solution will be to identify the other service that already created the zone and delete the DNS zone with that service. For example, Squarespace (and many other web hosting companies) also use NS1. Did you possibly use this domain at Squarespace previously?

We don’t have a way of knowing where else you might have used the domain. Also, NS1 won’t tell us which other customer created the DNS zone, only that one already exists. This means that we at Netlify cannot tell you who made it.

You might also reach out to NS1’s technical support team to see if they can tell you which customer of theirs already created a DNS zone for your domain.

We have a support guide which covers this issue here:

If you want to tell us the domain this is happening for, you can post that information publicly or you can private message (PM) that to one of our support staff. I’ve confirmed that PMs are enabled for your community login. Please keep in mind that only one person can see the PM and this will likely mean a slower reply than posting the information publicly. Please feel free to reply to however you prefer though.

Hey Luke,

Thanks for the advice, I haven’t used Squarespace but I did try Wix at one point. Not sure if they use NS1 as well but managed to get into my account and close it all together just in case. Still no luck though…

I’m in contact with name.com and they are escalating the issue for me but if that doesn’t work I’ll definitely reach out to NS1 directly. Do you happen to know the best place to contact them?

Thanks again,
Haden

Oh and the domain is hadenhiles.com in case you were wondering.

Cheers,
Haden

Hi, @HadenHiles. Name.com uses NS1. I think Wix does as well. If Name.com created the zone, the solution for that is here:

​Please let us know if there are other questions about this.