Support Forums

A DNS zone for this domain already exists on NS1 ERROR ERROR

Pre-emptively added the Netlify’s NS1 Name serves to my epik register- and getting the famous:
A DNS zone for this domain already exists on NS1

so I changed it back to default epik- same issue. deleted the site, waited couple hours- Epik sends me email when it finished changing, checked transversal- everything back to normal, tried again to get Netlify’s DNS no go. Sent support email - they won’t do anything about it. Never registered this domain anywhere, have a NS1 account for other domains. Tried it on NS1, same error after trying it at netlify.
(epik is not set up for this and I cannot SSl the domain now- so its useless if I dont get this fixed)

what can I do here?

Hi there, sorry to hear you are having some domain woes :frowning: Give this guide a read through, hopefully it will solve your problem. Let us know if it doesn’t.

No I am a experienced user- have checked all the avenues read all the posts on this. This forum seems to be where the netlify support team seems to be- they just flaked me off via the official support channel maybe I can beg support here…

Sent support email - they won’t do anything about it.

Just wanted to say that this is wrong – we will always do something about it. Just be aware, Starter customers get help here in the forums! We keep the discussion public so we can hopefully help others from the same pitfalls.

Never registered this domain anywhere

Maybe the domain was registered by somebody else in the past, on another service?

Tried it on NS1, same error after trying it at netlify.

If you read the guide, you’ll see we don’t ask you to check in at NS1 because, odds are, another provider who also uses NS1 has already created records at NS1. These won’t be under your control, but the reseller’s control.

Maybe the domain was previously used at Squarespace or Name.com like in the article, both of whom use NS1. But, as an experienced user, you’ll be able to find this out in no time!

We have this guide too, just for posterity: [Support Guide] I'm getting errors when adding my domain to Netlify or configuring DNS zones

Do let me know if issues persist.

In 3 minutes I got it fixed as I had a NS1 account for other domains- they told me they would contact netlify for me and fix it VS not ever at netlify. And no netlify will not fix it that is BS, have the support tickets to prove it. AND NS1 had to go to netlify to fix this issue :thinking: :thinking:

(site was never registered anywhere else [Epik], virgin domain, ONLY Netlify had the NS1 access)
Strongly suggest all netlify customers go with NS1 directly- there is zero benefit to integrate the dns with netlify- as it just creates issues they cannot fix and creates vendor lock in like crazy.

Hey there,

I’ll hold my hands up – I personally dealt with your first ticket in the Helpdesk, your escalation here and the NS1 ticket that came to us.

I’ll explain why I provided the advice that I did – which was incorrect.

You should be able to delete a Netlify DNS zone from your account, even if it is not associated with a site. From your team overview, you can click domains and your domain will appear in this list. You can click this to show the DNS zone. Alternatively, you can navigate to https://app.netlify.com/teams/[team]/dns/[domain]. Then, you can scroll to the bottom of the page and delete the DNS zone:

Because you can do this yourself in the UI, it’s not very often you see this pitfall. Usually, the issue of a DNS zone already existing arises when a third party also uses NS1 and the zone exists elsewhere. Therefore, that is what I based my response on.

So, when we were contacted by NS1 (who are clearly more diligent than me) I removed the zone which definitely did exist with us here at Netlify, which I had assumed would have been deleted from our UI. I will add that this isn’t an issue surrounding “vendor lock-in” – it’s just case of human error :slightly_smiling_face:.

I am glad this is at least up and posted so when someone else has the issue they can fix it here. See I knew the forum is the better place to be to get help :wink:

1 Like