500 - Internal Server Error | Nuxt css (Google Search)

PLEASE help us help you by writing a good post!

Screenshot 2023-11-18 183903

The link in question - https://www.sharif-sircar.com/_nuxt/index.f5b3d04d.css

@import"https://fonts.googleapis.com/css?family=Ubuntu:300,400";*[data-v-7c2c5364]{font-family:Ubuntu}.v-divider[data-v-7c2c5364]{margin-left:2%;margin-right:2%;opacity:10%}@media (min-width:959px){.imgStyles[data-v-7c2c5364]{border-radius:1%;box-shadow:2px 2px 4px #0003;max-height:90%}.individualChunk[data-v-7c2c5364]{padding-top:5%}.bio[data-v-7c2c5364],.jobTitle[data-v-7c2c5364]{padding-top:1.5%}.bio[data-v-7c2c5364]{font-size:1.2rem}.two-column[data-v-7c2c5364]{-moz-column-count:2;column-count:2;-moz-column-gap:1rem;column-gap:1rem}.skillCard[data-v-7c2c5364]{padding-right:2rem}}@media (max-width:959px){.mobilePhotos[data-v-7c2c5364]{display:none;max-width:50%}.bio[data-v-7c2c5364]{font-size:1rem;margin-left:2%;margin-right:2%}.topHeaders[data-v-7c2c5364]{text-align:center}}.v-card-text[data-v-7c2c5364]{font-size:1rem;margin-left:10px}ul.a[data-v-7c2c5364]{list-style-type:"\1f427"}li.list[data-v-7c2c5364]{margin-top:5px}

I have been trying to get to the bottom of this for months at this point! Any help is appreciated :pray:

Edit:
Would a robot.txt file prevent google from going there and basically solving this issue?

This doesn’t seem like a Netlify issue. Google indexed a broken version of your site for some reason - you need to work with Google to get that updated or removed from the index.

The CSS you’ve linked doesn’t have any importance here apart from the fact that Nuxt failed to load that CSS file when Google was indexing your website and thus, it appears there. The CSS file doesn’t even exist there anymore.

I have made a lot of updates to dependencies (Security vulnerabilities) and made further changes!

RE: Would a robot.txt file prevent google from going there or anywhere else and basically solving this issue?

However, what you said, do take me back to my original idea I have been wondering about and will try it out later tonight and request a recrawl from Google Search Console.

I will post back when my site is recrawled, if all the changes solved it

Solution was setting up the robot file, it prevented google crawling the /nuxt folder and I had to manually request a recrawl from the Google Search Console and it’s now solved.

1 Like

Thanks for posting the solution to help out others in this situation! Happy to hear that solved it.

1 Like

Now to remove my personal info off this post lol